Bug 31828 - udm-self does not work for non posix accounts
udm-self does not work for non posix accounts
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Change password
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Florian Best
Dirk Wiesenthal
:
Depends on: 36918
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-27 10:53 CEST by Janis Meybohm
Modified: 2015-01-08 13:59 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Error handling, External feedback, Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2013-06-27 10:53:31 CEST
Accounts without the "POSIX option" can't change their password via the udm-self module. Login works fine and the module is loaded successfully bot clicking the "Save changes" button does not trigger any visible action.

JS console (umc debug) says:
Uncaught TypeError: Cannot read property '$dn$' of null DetailPage.js:1316
(anonymous function) DetailPage.js:1316
lang.mixin.forIn dojo.js.uncompressed.js:17105
declare.getAlteredValues DetailPage.js:1315
declare.validateChanges DetailPage.js:1067
(anonymous function) dojo.js.uncompressed.js:37730
dispatcher.around.advice dojo.js.uncompressed.js:67444
target.(anonymous function).dispatcher dojo.js.uncompressed.js:67426
declare._onSubmit dojo.js.uncompressed.js:32877
(anonymous function)


UDM umc module says:
==> /var/log/univention/management-console-module-udm.log <==
26.05.13 16:42:59.523  MAIN        ( INFO    ) : Incoming connection from 
26.05.13 16:42:59.533  PARSER      ( INFO    ) : UMCP REQUEST 136957937952236-9 parsed successfully
26.05.13 16:42:59.533  MODULE      ( INFO    ) : Received request 136957937952236-9
26.05.13 16:42:59.533  PROTOCOL    ( INFO    ) : Received UMCP SET REQUEST 136957937952236-9
26.05.13 16:42:59.534  MODULE      ( WARN    ) : Specified locale is not available (en_US.UTF-8)
26.05.13 16:42:59.534  MODULE      ( WARN    ) : Falling back to C
26.05.13 16:42:59.534  MODULE      ( INFO    ) : Setting user LDAP DN None
26.05.13 16:42:59.534  MODULE      ( INFO    ) : Saved LDAP DN for user None
26.05.13 16:42:59.535  MODULE      ( INFO    ) : Opening LDAP connection for user None
...
...
==> /var/log/univention/management-console-module-udm.log <==
26.05.13 16:30:44.599  PARSER      ( INFO    ) : UMCP REQUEST 136957864459148-53 parsed successfully
26.05.13 16:30:44.599  MODULE      ( INFO    ) : Received request 136957864459148-53
26.05.13 16:30:44.599  PROTOCOL    ( INFO    ) : Received UMCP COMMAND REQUEST 136957864459148-53
26.05.13 16:30:44.599  MODULE      ( INFO    ) : Executing ['udm/get']
26.05.13 16:30:44.599  MODULE      ( INFO    ) : Starting thread for udm/get request
26.05.13 16:30:44.600  MODULE      ( INFO    ) : Using open LDAP connection for user None
26.05.13 16:30:44.600  MODULE      ( PROCESS ) : A module for the LDAP DN None could not be found
26.05.13 16:30:44.610  PROTOCOL    ( INFO    ) : Sending UMCP RESPONSE 136957864459148-53


Looks like the DN was never provided to the UDM module.
Comment 1 Janis Meybohm univentionstaff 2013-06-27 10:57:59 CEST
Reportet by customer: http://forum.univention.de/viewtopic.php?f=48&t=2722
Comment 2 Florian Best univentionstaff 2014-11-28 11:27:12 CET
Very interesting. Maybe this is the entry point to understand Bug #36918.
Comment 3 Florian Best univentionstaff 2014-12-04 17:21:51 CET
Can probably be marked as duplicate of Bug #36918. Maybe some things in the JavaScript are also necessary. We'll see.
Comment 4 Florian Best univentionstaff 2014-12-09 13:45:02 CET
This has been fixed in Bug #37178. I am using this bug for the correct error handling (= changes in UDM):
If the LDAP DN of a user can't be determined the UDM module now shows a error message with suggestions what to do (including checking the join status, DNS-problems, ...).

Package: univention-management-console-module-udm (5.1.25-8)
YAML: 2014-11-25-univention-management-console-module-udm.yaml
Downgradeable to UCS 3.2-4: possible
Comment 5 Dirk Wiesenthal univentionstaff 2015-01-07 17:23:06 CET
Hard to reproduce now to see the helpful error message.

Changeset: OK
YAML: OK
Comment 6 Janek Walkenhorst univentionstaff 2015-01-08 13:59:05 CET
http://errata.univention.de/ucs/4.0/18.html