Bug 31902 - UCC: printer moderation
UCC: printer moderation
Status: CLOSED FIXED
Product: UCS@school
Classification: Unclassified
Component: UCC
UCS@school 3.1 R2
Other Linux
: P5 normal (vote)
: UCS@school 3.1 R2 Errata
Assigned To: Erik Damrose
Felix Botner
:
: 30853 (view as bug list)
Depends on:
Blocks: 32009 32055 32056
  Show dependency treegraph
 
Reported: 2013-07-05 14:56 CEST by Sönke Schwardt-Krummrich
Modified: 2013-07-25 12:39 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2013-07-05 14:56:32 CEST
The UCC integration into UCS@school should also cover the printer moderation.

Software on the UCC client is able to use the CUPS server on the school slave by simply setting the environment variable CUPS_SERVER.
→ automatic configuration of the printserver on the UCC client

Since all printer restrictions are done via samba shares, the UCC client would bypass these restrictions when connecting directly to the CUPS server.
→ the UCC client has to be subject to all regular UCS@school print restrictions
   Possible solutions for 2):
   - add the same restrictions to the CUPS config
   - the UCC client uses the samba printer shares
Comment 1 Erik Damrose univentionstaff 2013-07-18 12:33:12 CEST
univention-printserver 6.0.21-2.613.201307181044, build in errata3.1-1
2013-07-18-univention-printserver.yaml

ucs-school-umc-computerroom 3.0.13-4.109.201307181101 build in ucsschool-3.1-R2
changelog entry added

Support has been added to restrict cups printer access based on ip addresses. New ucr variables cups/printmode/hosts have been defined and are set by the computerroom module.

NOTE: Currently only restricting access from a computerroom is supported. Allowing printing from a room for which printer share restrictions would prevent it is not implemented. This feature will be implemented by bug 32009.

The package univention-ucc-printerconfig (1.0.0-1.1.201307181224) has been created and build in ucc-errata. It allows configuration of cups' client.conf with the use of UCRV ucc/cups/server and defaults to localhost.
2013-07-18-univention-ucc-printerconfig.yaml
Comment 2 Erik Damrose univentionstaff 2013-07-18 14:42:43 CEST
Also build for UCS 3.2: univention-printserver 7.0.3-1.614.201307181411, changelog entry added.
Comment 3 Erik Damrose univentionstaff 2013-07-23 10:39:50 CEST
*** Bug 30853 has been marked as a duplicate of this bug. ***
Comment 4 Felix Botner univentionstaff 2013-07-24 14:52:54 CEST
please clone this bug for:
 * univention-printserver -> Target Milestone UCS 3.1-1-errata
 * univention-ucc-printerconfig -> Target Milestone UCC 1.0-errata

please add package dependencies to
 * ucs-school-ucc-integration (univention-printserver >= errata version, 
   ucs-school-umc-computerroom >= ucs@schoolr2 version)
 * univention-ucc-ucsschool-integration (univention-ucc-printerconfig)
Comment 5 Erik Damrose univentionstaff 2013-07-24 16:21:35 CEST
Bugs were cloned -> Bug 32055 Bug 32056 

Dependency added: univention-ucc-ucsschool-integration depends on univention-ucc-printerconfig:
univention-ucc-ucsschool-integration 1.0.2-2.4.201307241605, yaml file updated

Dependency added: ucs-school-ucc-integration depends on univention-printserver (>= 6.0.21-3) and univention-ucs-school-umc-computerroom (>= 3.0.13-4).
ucs-school-ucc-integration 1.0.4-3.8.201307241615
Comment 6 Felix Botner univentionstaff 2013-07-24 16:34:31 CEST
apt-get -s install ucs-school-ucc-integration
ucs-school-ucc-integration : Hängt ab von: univention-ucs-school-umc-computerroom (>= 3.0.13-4) ist aber nicht installierbar

the name of the package is  "ucs-school-umc-computerroom"
Comment 7 Erik Damrose univentionstaff 2013-07-24 16:45:18 CEST
I do not know how that extra 'univention' did slip in there. New Version:

ucs-school-ucc-integration 1.0.4-4.9.201307241641
Comment 8 Felix Botner univentionstaff 2013-07-24 16:56:19 CEST
OK - package dependencies in ucs-school-ucc-integration 
     (univention-printserver, ucs-school-umc-computerroom)

OK - UMC module, deactivate printing in umc computerroom module
     immediately disable printing for cups clients in the computerroom

OK - Changelog
Comment 9 Moritz Muehlenhoff univentionstaff 2013-07-25 12:39:39 CEST
http://errata.univention.de/ucc/1.0/20.html