Bug 31957 - univention-user-quota throws exception when evaluating quota
univention-user-quota throws exception when evaluating quota
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Quota
UCS 3.1
Other Linux
: P5 minor (vote)
: UCS 3.1-1-errata
Assigned To: Lukas Walter
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-11 11:44 CEST by Jan Christoph Ebersbach
Modified: 2013-07-25 10:52 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Christoph Ebersbach univentionstaff 2013-07-11 11:44:28 CEST
I created a separate partition for /home, enabled quota and assigned a quota policy to a share below /home.

Finally, I ran /usr/sbin/univention-user-quota USERNAME on the command line and received the following traceback:

/usr/sbin/univention-user-quota
  File "/usr/sbin/univention-user-quota", line 158, in <module>
    log.write('no quota for %s\n') % mountpoint_path
TypeError: unsupported operand type(s) for %: 'NoneType' and 'str'

The error is caused by this programming mistake:
  log.write('no quota for %s\n') % mountpoint_path
It should be:
  log.write('no quota for %s\n' % mountpoint_path)
Comment 1 Lukas Walter univentionstaff 2013-07-11 13:31:47 CEST
A typo. Fixed for ucs3-2.0 and errata3.1-1.

No changelog entry for ucs-3.2-0 because the script has been rewritten since the last release in terms of Bug #30636, for which there is a note in the changelog already.

Errata 3.1-1 YAML:
==================
product: ucs
release: "3.1"
scope: ucs_3.1-0-errata3.1-1
src: univention-quota
fix: 7.0.5-10.114.201307111315
note:
version: [1]
desc: |
    This errata update removes a typo which caused a traceback in the
    univention-user-quota script.
bug: [31957]
Comment 2 Felix Botner univentionstaff 2013-07-15 16:54:04 CEST
FAIL - 3.2 changelog

OK - errata3.1-1
OK - ucs3.2-0
OK - YAML
Comment 3 Lukas Walter univentionstaff 2013-07-17 09:31:20 CEST
Added this bug number to 3.2 changelog entry for Bug #30636.
Comment 4 Felix Botner univentionstaff 2013-07-19 12:57:58 CEST
OK
Comment 5 Moritz Muehlenhoff univentionstaff 2013-07-25 10:52:56 CEST
http://errata.univention.de/ucs/3.1/154.html