Bug 31994 - rename ou (underscore -> white space) with win ad tools failed in connectors
rename ou (underscore -> white space) with win ad tools failed in connectors
Status: RESOLVED DUPLICATE of bug 33482
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2-x
Assigned To: Connector maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-17 11:33 CEST by Felix Botner
Modified: 2013-11-26 09:07 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2013-07-17 11:33:18 CEST
UCS 3.1-1 + Samba4 and a win7 with ad tools

With the windows ad tools I created a ou Test_ifbaa. Then i renamed this ou to "Test ifbaa".  

ou created:
sync to ucs:   [            ou] [       add] OU=Test_ifbaa,dc=hans,dc=de
sync from ucs: [            ou] [       add] ou=test_ifbaa,dc=hans,dc=de

ou renamed:
sync to ucs:   [            ou] [    modify] OU=Test ifbaa,dc=hans,dc=de
12.07.2013 09:04:59,611 LDAP        (INFO   ): sync_to_ucs: set position to dc=hans,dc=de
12.07.2013 09:04:59,615 LDAP        (INFO   ): __set_values: set attribute, ucs_key: name - value: [u'Test ifbaa']
12.07.2013 09:04:59,625 LDAP        (INFO   ): __set_values: module container/ou has custom attributes
12.07.2013 09:04:59,625 LDAP        (INFO   ): set key in ucs-object: name
12.07.2013 09:04:59,634 LDAP        (INFO   ): __set_values: no ldap_attribute defined in <univention.s4connector.attribute instance at 0x95574ec>, we unset the key description in the ucs-object
12.07.2013 09:04:59,642 LDAP        (INFO   ): __set_values: no ldap_attribute defined in <univention.s4connector.attribute instance at 0x955750c>, we unset the key gPLink in the ucs-object
12.07.2013 09:04:59,643 LDAP        (ERROR  ): Unknown Exception during sync_to_ucs
12.07.2013 09:04:59,643 LDAP        (ERROR  ): Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/univention/s4connector/__init__.py", line 1311, in sync_to_ucs
    result = self.modify_in_ucs(property_type, object, module, position)
  File "/usr/lib/pymodules/python2.6/univention/s4connector/__init__.py", line 1178, in modify_in_ucs
    return ucs_object.modify() and self.__modify_custom_attributes(property_type, object, ucs_object, module, position)
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 344, in modify
    return self._modify(modify_childs,ignore_license=ignore_license)
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 727, in _modify
    self._ldap_pre_modify()
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/container/ou.py", line 277, in _ldap_pre_modify
    self.move(newdn)
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 358, in move
    raise univention.admin.uexceptions.ldapError, _('Moving not possible: old and new DN are identical.')
ldapError: Moving not possible: old and new DN are identical.

-> univention-s4connector-list-rejected

S4 rejected

    1:    S4 DN: OU=notebooks,OU=Test ifbaa,DC=hans,DC=de
         UCS DN: <not found>
    2:    S4 DN: OU=Test ifbaa,DC=hans,DC=de
         UCS DN: <not found>

        last synced USN: 5200
Comment 1 Stefan Gohmann univentionstaff 2013-11-26 09:07:13 CET
Will be fixed with Bug #33482 / Bug #33566

*** This bug has been marked as a duplicate of bug 33482 ***