Bug 32043 - Postlogin screen for XenApp session
Postlogin screen for XenApp session
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Terminal services
unspecified
Other Linux
: P5 enhancement
: UCC 2.0
Assigned To: Moritz Muehlenhoff
Felix Botner
: interim-3
: 30849 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-23 14:39 CEST by Moritz Muehlenhoff
Modified: 2014-06-12 09:20 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2013-07-23 14:39:29 CEST
In #2013060521001746 a menu selection was added to the XenApp session script: Once a XenApp session has been terminated by quitting Firefox, a Zenity selection menu is displayed, offering:
- A relogin to XenApp
- Shutdown of the client
- Return to LightDM
Comment 1 Moritz Muehlenhoff univentionstaff 2013-12-18 09:26:24 CET
*** Bug 30849 has been marked as a duplicate of this bug. ***
Comment 2 Moritz Muehlenhoff univentionstaff 2014-04-07 11:10:09 CEST
If the automatic LightDM session login has been selected and if the session is configured to XenApp, a post login screen is now displayed (internationalised in German and English) which allows
- A relogin to XenApp
- Shutdown of the client
- Return to LightDM
Comment 3 Felix Botner univentionstaff 2014-04-28 17:22:26 CEST
When should the post login screen be displayed?
The only way to get this dialog i found is the firefox close button in the usually hidden firefox tab bar.
Comment 4 Felix Botner univentionstaff 2014-04-28 17:23:48 CEST
also, 

sessions/XenApp +76
lang=$(locale | grep LANGUAGE | cut -d= -f2 | cut -d_ -f1 | head -1)

LANGUAGE is not set in my ucc client, but LANG
Comment 5 Moritz Muehlenhoff univentionstaff 2014-04-30 09:57:46 CEST
(In reply to Felix Botner from comment #3)
> When should the post login screen be displayed?
> The only way to get this dialog i found is the firefox close button in the
> usually hidden firefox tab bar.

This and alt+F4 (plus potential crashes of the Citrix Receiver or connections which have been terminated otherwise).(In reply to Felix Botner from comment #4)
> also, 
> 
> sessions/XenApp +76
> lang=$(locale | grep LANGUAGE | cut -d= -f2 | cut -d_ -f1 | head -1)
> 
> LANGUAGE is not set in my ucc client, but LANG

Fixed, now the post login screen is internationalised again.
Comment 6 Felix Botner univentionstaff 2014-05-07 10:47:53 CEST
OK
Comment 7 Moritz Muehlenhoff univentionstaff 2014-06-12 09:20:03 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".