Bug 32146 - UCR Policies: attributes are unsorted
UCR Policies: attributes are unsorted
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Policies
UCS 4.0
Other Linux
: P5 normal with 2 votes (vote)
: UCS 4.0-2-errata
Assigned To: Florian Best
Johannes Keiser
:
: 19116 33013 34810 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 11:06 CEST by Ingo Steuwer
Modified: 2015-07-03 14:10 CEST (History)
8 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ingo Steuwer univentionstaff 2013-08-02 11:06:25 CEST
There seems to be no sort criteria for the attributes in an UCR policy.
Comment 1 Philipp Hahn univentionstaff 2014-07-04 15:03:17 CEST
+1
Comment 2 Jan Christoph Ebersbach univentionstaff 2014-11-20 21:36:06 CET
Still true for UCS 4.0.
Comment 3 Jan Christoph Ebersbach univentionstaff 2014-11-20 21:37:21 CET
Especially in lager environments this makes using UCR Policies extremely tedious.
Comment 4 Florian Best univentionstaff 2015-05-28 17:50:56 CEST
UCR-Variables are now sorted.
Fix: svn r60926
YAML: 2015-05-28-univention-directory-manager-modules.yaml
Comment 5 Florian Best univentionstaff 2015-05-29 16:42:59 CEST
*** Bug 33013 has been marked as a duplicate of this bug. ***
Comment 6 Johannes Keiser univentionstaff 2015-06-12 13:12:49 CEST
In the "Policies" module the variables are sorted but not in the LDAP directory.
Comment 7 Florian Best univentionstaff 2015-06-17 18:35:18 CEST
*** Bug 34810 has been marked as a duplicate of this bug. ***
Comment 8 Florian Best univentionstaff 2015-06-17 18:35:24 CEST
*** Bug 19116 has been marked as a duplicate of this bug. ***
Comment 9 Florian Best univentionstaff 2015-06-17 18:36:23 CEST
(In reply to Florian Best from comment #8)
> *** Bug 19116 has been marked as a duplicate of this bug. ***
As the variables are sorted now it is better to fix this bug, too.
Comment 10 Johannes Keiser univentionstaff 2015-06-25 14:39:00 CEST
Changes: OK
YAML: OK

 Verified
Comment 11 Janek Walkenhorst univentionstaff 2015-07-03 14:10:15 CEST
<http://errata.univention.de/ucs/4.0/217.html>