Bug 32299 - Reload XML files for module meta information upon login (e.g. to update the list of ""Installed Applications")
Reload XML files for module meta information upon login (e.g. to update the l...
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Florian Best
Dirk Wiesenthal
: interim-3
Depends on:
Blocks: 32408
  Show dependency treegraph
 
Reported: 2013-08-22 12:18 CEST by Alexander Kläser
Modified: 2013-11-19 06:41 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kläser univentionstaff 2013-08-22 12:18:27 CEST
In case a new UMC module has been installed, the UMC server needs at least a reload to re-read the new XML meta files. It would render the handling of module installations easier if the XML files would be re-read upon login.
Comment 1 Felix Botner univentionstaff 2013-09-20 09:51:30 CEST
e.g. AppCenter

if i install/deinstall apps with univention-add-app or apt-get remove, the list of installed apps in the umc's "Installed Applications" module is not automatically updated, i need to

-> ucr commit /usr/share/univention-management-console/modules/apps.xml
-> /etc/init.d/univention-management-console-server reload

in order to have a correct "Installed Applications" list

it would be nice if that happens during UMC login
Comment 2 Alexander Kläser univentionstaff 2013-09-20 16:30:32 CEST
It could also be helpful if the App Center XML file is committed on login to make sure that the data is consistent (maybe via login hook scripts that are executed upon login).
Comment 3 Dirk Wiesenthal univentionstaff 2013-09-20 17:13:23 CEST
The AppCenter XML files are committed after app (un)installation. They should be consistent all the time. The problem is UMC not reloading them.

The only way to get the XML files into an inconsistent state is to apt-get uninstall some packages needed for the app by hand.
Comment 4 Alexander Kläser univentionstaff 2013-10-10 15:48:33 CEST
A little change for UMC a much bigger change for other places, e.g., Bug 32408. Adding this functionality will ease the replication of UDM modules.
Comment 5 Florian Best univentionstaff 2013-10-10 15:50:56 CEST
fixed in
univention-management-console (6.0.16-1) 
* Bug #32299: reload categories, modules and UCR variable on auth request
Comment 6 Dirk Wiesenthal univentionstaff 2013-10-31 21:47:54 CET
Changelog Ok
Changeset Ok - which surprises me. I was unable to come up with situations where this may lead to problems. It is even almost possible to do it on F5 (get/modules/list) but I think at the moment some things may go wrong (although probably not in >99%).

Maybe some day we can implement it this way. Then a UMC-server restart would only be necessary on umc-server package updates!
Comment 7 Stefan Gohmann univentionstaff 2013-11-19 06:41:54 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".