Bug 32580 - Firefox profile configuration broken
Firefox profile configuration broken
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: General
unspecified
Other Linux
: P5 normal
: UCC 1.0-errata
Assigned To: Felix Botner
Moritz Muehlenhoff
:
: 32093 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-12 15:33 CEST by Jan Christoph Ebersbach
Modified: 2014-01-09 08:35 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Christoph Ebersbach univentionstaff 2013-09-12 15:33:01 CEST
With FF 21 Mozilla broke the location where a default profile is configured.  ucc_proxy configuration is likely to be broken for UCC as well. At least in my tests with an up-to-date custom image, none of the settings were applied.

More information at: http://mike.kaply.com/2013/04/24/major-changes-coming-in-firefox-21/
Comment 1 Felix Botner univentionstaff 2013-09-26 15:09:07 CEST
*** Bug 32093 has been marked as a duplicate of this bug. ***
Comment 2 Felix Botner univentionstaff 2013-09-26 15:38:26 CEST
(In reply to Jan Christoph Ebersbach from comment #0)
> With FF 21 Mozilla broke the location where a default profile is configured.
> ucc_proxy configuration is likely to be broken for UCC as well. At least in
> my tests with an up-to-date custom image, none of the settings were applied.

no, the default user preferences can still be configured in /usr/lib/firefox/defaults/pref/

But i changed the firefox config settings from user_pref (default but mutable) to lockPref (default and immutable) in /usr/lib/firefox/defaults/pref/ucc-proxy.js.

-> ucr set ucc/proxy/http=http://10.200.7.130:3128
-> more /usr/lib/firefox/defaults/pref/ucc-proxy.js
...
lockPref("network.proxy.type", 1);
lockPref("network.proxy.http", "10.200.7.130");
lockPref("network.proxy.http_port", 3128);
lockPref("network.proxy.ftp", "10.200.7.130");
lockPref("network.proxy.ftp_port", 3128);
lockPref("network.proxy.socks", "10.200.7.130");
lockPref("network.proxy.socks_port", 3128);
lockPref("network.proxy.ssl", "10.200.7.130")
...

-> firefox -> according proxy settings -> proxy settings are immutable

univention-ucc-proxy-settings: ucc-errata
1.0.0-5.5.201309261523

YAML: 2013-09-26-univention-ucc-proxy-settings.yaml
Comment 3 Moritz Muehlenhoff univentionstaff 2014-01-08 11:25:19 CET
The proxy settings are applied to the current Firefox in UCC and cannot be altered by the user.
Comment 4 Moritz Muehlenhoff univentionstaff 2014-01-09 08:35:00 CET
http://errata.univention.de/ucc/1.0/29.html