Bug 32655 - [Internet Explorer] Host dropdown
[Internet Explorer] Host dropdown
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.1
Other Linux
: P5 minor (vote)
: UCS 3.2-0-errata
Assigned To: Florian Best
Erik Damrose
https://bugs.dojotoolkit.org/ticket/1...
:
: 31632 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 11:45 CEST by Florian Best
Modified: 2014-02-12 10:27 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Browser compatibility
Max CVSS v3 score:


Attachments
Screenshot (207.10 KB, image/png)
2013-09-20 11:45 CEST, Florian Best
Details
Host drop down in different browsers (50.97 KB, image/png)
2014-01-27 10:19 CET, Alexander Kläser
Details
Patch of current changes (1.34 KB, patch)
2014-01-27 10:29 CET, Alexander Kläser
Details | Diff
small glitches with current version 3.0.152-21 (751.72 KB, image/png)
2014-02-11 16:19 CET, Erik Damrose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2013-09-20 11:45:35 CEST
Created attachment 5454 [details]
Screenshot

The selected item in the host dropdown is not correctly displayed as you can see in the screenshot.
Also the texts ('Host: ', 'Username: ') aren't aligned correctly, the Username text should be 1px lower.
Comment 1 Florian Best univentionstaff 2013-09-20 11:59:04 CEST
I accidentally fixed the not aligned pixel.

So only the issue with the disabled entry remains.
Comment 2 Florian Best univentionstaff 2014-01-24 17:07:37 CET
Most parts have been addressed but there are still issues with IE10.
Comment 3 Alexander Kläser univentionstaff 2014-01-27 10:19:40 CET
Created attachment 5755 [details]
Host drop down in different browsers

Current status (see attached image):
IE8:      alignment → OK;   drop down → OK
IE9:      alignment → OK;   drop down → FAIL
IE10:     alignment → OK;   drop down → FAIL
FF:       alignment → FAIL; drop down → FAIL
Chromium: alignment → FAIL; drop down → FAIL
Comment 4 Alexander Kläser univentionstaff 2014-01-27 10:29:08 CET
Created attachment 5756 [details]
Patch of current changes

I reverted the current changes to allow the announce of the current errata changes.

univention-management-console-frontend (3.0.153-1):
* Bug #32655: reverted changes from r47379 for next erratum
Comment 5 Florian Best univentionstaff 2014-01-31 15:24:22 CET
drop down: svn47561
alignment: svn47562

univention-management-console-frontend (3.0.152-18) 
* Bug #32655: fix host dropdown design and alignment

YAML: 2014-01-31-univention-management-console-frontend.yaml
Comment 6 Florian Best univentionstaff 2014-02-07 22:29:31 CET
*** Bug 31632 has been marked as a duplicate of this bug. ***
Comment 7 Erik Damrose univentionstaff 2014-02-11 16:19:30 CET
Created attachment 5790 [details]
small glitches with current version 3.0.152-21

host-dropdown transparency/display issues resolved, a minor glitch is visible with ie 11 (top line of the selected item has a dark green color).

1 pixel offset still present in chromium 32, ie 8; It is now 1 pixel too _low_ in ie 11
Comment 8 Erik Damrose univentionstaff 2014-02-11 16:24:15 CET
We think it is way better than before, so VERIFIED for release
yaml: OK
Comment 9 Moritz Muehlenhoff univentionstaff 2014-02-12 10:27:37 CET
http://errata.univention.de/ucs/3.2/61.html