Bug 32813 - listener traceback during installation
listener traceback during installation
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Arvid Requate
Stefan Gohmann
: interim-2
: 27890 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 11:15 CEST by Felix Botner
Modified: 2014-11-26 06:55 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2013-10-07 11:15:16 CEST
I got the following traceback in the listener log during the installation of the univention-s4-connector. It is not a big problem, everything works 

Traceback (most recent call last):
  File "/usr/lib/univention-directory-listener/system/s4-connector.py", line 139, in clean
    for filename in os.listdir(directory):
OSError: [Errno 2] No such file or directory: '/var/lib/univention-connector/s4'
Traceback (most recent call last):
  File "/usr/lib/univention-directory-listener/system/s4-connector.py", line 173, in initialize
    clean()
  File "/usr/lib/univention-directory-listener/system/s4-connector.py", line 139, in clean
    for filename in os.listdir(directory):
OSError: [Errno 2] No such file or directory: '/var/lib/univention-connector/s4'
Comment 1 Arvid Requate univentionstaff 2014-08-25 19:00:03 CEST
*** Bug 27890 has been marked as a duplicate of this bug. ***
Comment 2 Arvid Requate univentionstaff 2014-08-25 19:14:04 CEST
Fixed, changelog adjusted.
Comment 3 Stefan Gohmann univentionstaff 2014-09-30 06:46:44 CEST
Code Review: OK (r53013)

Test: OK

Changelog: OK
Comment 4 Stefan Gohmann univentionstaff 2014-11-26 06:55:57 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".