Bug 32818 - Traceback: "Connection reset by peer" on network reconfiguration not handled
Traceback: "Connection reset by peer" on network reconfiguration not handled
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: System setup
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-3-errata
Assigned To: Sönke Schwardt-Krummrich
Stefan Gohmann
:
Depends on:
Blocks: 28670 33091 36561 37036 37167
  Show dependency treegraph
 
Reported: 2013-10-08 11:33 CEST by Philipp Hahn
Modified: 2014-12-03 17:15 CET (History)
6 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
klaeser: Patch_Available+


Attachments
Catch socker error (4.83 KB, patch)
2013-10-08 12:53 CEST, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2013-10-08 11:33:52 CEST
# tail -f /var/log/univention/management-console-module-setup.log
08.10.13 11:23:27.939  PROTOCOL    ( INFO    ) : Sending UMCP RESPONSE 138122420793716-1
08.10.13 11:23:28.027  MODULE      ( ERROR   ) : Traceback (most recent call last):
  File "/usr/sbin/univention-management-console-module", line 112, in <module>
    notifier.loop()
  File "/usr/lib/pymodules/python2.6/notifier/nf_generic.py", line 284, in loop
    step()
  File "/usr/lib/pymodules/python2.6/notifier/nf_generic.py", line 271, in step
    not __sockets[ cond ][ fd ]( sock_obj ):
  File "/usr/lib/pymodules/python2.6/univention/management/console/protocol/modserver.py", line 129,
 in _recv
    data = socket.recv( RECV_BUFFER_SIZE )
error: [Errno 104] Connection reset by peer

# tail /var/log/univention/management-console-server.log
08.10.13 11:23:26.539  SSL         ( WARN    ) : SSL error in _receive: [('SSL routines', 'SSL23_READ', 'ssl handsha
08.10.13 11:23:27.936  DEBUG_INIT
08.10.13 11:23:27.936  MAIN        ( PROCESS ) : Stopping UMC server ...
08.10.13 11:23:27.937  MAIN        ( WARN    ) : Shutting down all open connections
08.10.13 11:23:27.947  MAIN        ( PROCESS ) : Starting UMC server ...
08.10.13 11:23:28.266  MAIN        ( PROCESS ) : Server started

# tail /var/log/univention/management-console-web-server.log
08.10.13 11:14:06.499  MAIN        ( PROCESS ) : SessionClient(0x2b88390): _authenticated: success=True  status=200  message=OK, operation successful
08.10.13 11:23:28.124  MAIN        ( PROCESS ) : UMCP_Dispatcher: check_queue: invalid session: sessionid='47bf040b-e94b-4291-8ca1-33c1a0702eb8'
08.10.13 11:23:28.124  MAIN        ( PROCESS ) : CPCommand (192.168.0.191:60232) response status code: 401
08.10.13 11:23:28.124  MAIN        ( PROCESS ) : CPCommand (192.168.0.191:60232) response message: None
08.10.13 11:23:28.124  MAIN        ( PROCESS ) : CPCommand (192.168.0.191:60232) response result: None
08.10.13 11:23:28.225  MAIN        ( WARN    ) : SessionClient(0x2b88a50): connection to UMC server failed
08.10.13 11:23:28.225  MAIN        ( PROCESS ) : Failed to create UMC connection: Connection failed
08.10.13 11:23:28.225  MAIN        ( PROCESS ) : CPRoot/auth: username: None, status code: 401
08.10.13 11:23:28.341  DEBUG_INIT
08.10.13 11:23:28.341  MAIN        ( PROCESS ) : Stopping UMC web server ...
08.10.13 11:23:28.343  MAIN        ( PROCESS ) : The UMC web server is still running. Will wait for 5 seconds
08.10.13 11:23:28.844  MAIN        ( PROCESS ) : Starting UMC web server ...

Browser is stuck in
  Generating SSL certificate
  93%
Comment 1 Philipp Hahn univentionstaff 2013-10-08 12:53:06 CEST
Created attachment 5504 [details]
Catch socker error
Comment 2 Alexander Kläser univentionstaff 2013-10-09 12:43:46 CEST
In which circumstances does this problem occur?
Comment 3 Tim Petersen univentionstaff 2013-12-24 08:44:26 CET
(In reply to Alexander Kläser from comment #2)
> In which circumstances does this problem occur?

I saw this several times in customers management-console-module-appcenter.log while installing or deinstalling apps - but I have no idea what lead to this.
Comment 4 Sönke Schwardt-Krummrich univentionstaff 2014-11-06 11:59:28 CET
(In reply to Alexander Kläser from comment #2)
> In which circumstances does this problem occur?

It happened when the UMC server was restarted several times. Looks like a timing issue.

Socket exceptions during recv() are now catched via try-except. If an exception appeared, the socket is closed and removed from notifier.
If the UMC module notices, that the closed socket was the UNIX socket to the UMC server, the UMC module shut down immediately, because the UMC server will not reestablish the UNIX socket connection but start a new UMC module instance instead.

YAML: 2014-10-28-univention-management-console.yaml

The patch has been also ported to UCS 4.0.
Comment 5 Stefan Gohmann univentionstaff 2014-11-06 14:58:20 CET
YAML: OK

Reproduction: I was not able to reproduce it.

Code: OK

Tests: OK

4.0 merge: OK

UMC ucs-test: OK
Comment 6 Janek Walkenhorst univentionstaff 2014-11-07 15:37:49 CET
http://errata.univention.de/ucs/3.2/238.html