Bug 32843 - Searching underneath of cn=univention for a specific object type does not work
Searching underneath of cn=univention for a specific object type does not work
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - LDAP directory
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 4.1-1-errata
Assigned To: Florian Best
Alexander Kläser
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-11 10:48 CEST by Daniel Orrego
Modified: 2016-03-18 06:43 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Usability
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Orrego univentionstaff 2013-10-11 10:48:34 CEST
Trying to filter 'UMC Operation Set' objects in UMC doesn't show any results.

Steps to reproduce (in a UCS Master):

* Open LDAP Directory in UMC
* Go to [LDAPbase]->univention->UMC->operations
* Choose "Settings: UMC Operation Set" as LDAP Object type and click 'Search'

No results are shown.
Comment 1 Florian Best univentionstaff 2016-03-04 14:19:03 CET
Caused by the following line:
 525 »   »   »   »   »   request.options['container'] = superordinate.dn
settings/cn is detected as superordinate and overwrites therefore the specified container. It searches therefore in the parent container.

univention-management-console-module-udm (6.0.11-8):
r67913 | Bug #32843: repair search underneath of cn=univention

univention-management-console-module-udm.yaml:
r67914 | YAML Bug #32843
Comment 2 Alexander Kläser univentionstaff 2016-03-14 16:45:13 CET
Changes: OK
YAML file: OK

→ VERIFIED
Comment 3 Florian Best univentionstaff 2016-03-18 06:43:40 CET
<http://errata.software-univention.de/ucs/4.1/133.html>