Bug 32852 - Connector can skip changes in init mode
Connector can skip changes in init mode
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: S4 Connector
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2
Assigned To: Stefan Gohmann
Arvid Requate
: interim-3
Depends on:
Blocks: 32768
  Show dependency treegraph
 
Reported: 2013-10-12 17:01 CEST by Stefan Gohmann
Modified: 2013-11-19 06:43 CET (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-10-12 17:01:27 CEST
Observed while working on Bug #32768. The connector does not probably sync every object if the connector is restarted in the init phase. The problem is the interaction between usnchanged and usncreated.

In the init phase the connector searches for usncreated but the connector saves the usnchanged number which is probably higher. For example:

dn: object1
usnChanged: 10
usnCreated: 1

dn: object2
usnChanged: 8
usnCreated: 2

First the connector syncs object1 and then saves the usnChanged number. If the connector is now restarted, object2 will not be synced.
Comment 1 Stefan Gohmann univentionstaff 2013-10-12 21:05:23 CEST
That is not complete right. The problem occurs only if objects are rejected in the initialization phase.

Fix: r45010
Changelog: r45011
Comment 2 Arvid Requate univentionstaff 2013-10-30 19:51:35 CET
Code Ok, doing the same as the AD-Connector first change from Bug #22622 Comment 3.
Changelog Ok.
Comment 3 Stefan Gohmann univentionstaff 2013-11-19 06:43:13 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".