Bug 32871 - Hide special users and groups
Hide special users and groups
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 3.1
Other Linux
: P5 enhancement (vote)
: UCS 3.2
Assigned To: Stefan Gohmann
Lukas Walter
: interim-3
: 31042 (view as bug list)
Depends on: 31408
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 17:58 CEST by Stefan Gohmann
Modified: 2013-12-06 07:25 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-10-15 17:58:28 CEST
We should hide the following users by default:
 - join-backup
 - join-slave
 - dns-*

And these pseudo groups:
- Authenticated Users
- World Authority
- Everyone
- Null Authority
- Nobody
- Enterprise Domain Controllers


+++ This bug was initially created as a clone of Bug #31408 +++

It would be nice if univentionObjectFlag can be set via the UDM interface (CLI and python API).
Comment 1 Stefan Gohmann univentionstaff 2013-10-15 21:55:40 CEST
fixed

univention-samba4: r45127, r45129, r45130, r45136
univention-join: r45128
changelog: r45137
Comment 2 Moritz Muehlenhoff univentionstaff 2013-10-22 13:27:50 CEST
On a fresh UCS 3.2 installation(In reply to Stefan Gohmann from comment #0)
> We should hide the following users by default:
>  - join-backup
>  - join-slave
>  - dns-*

On a fresh installation the dns-master user is still present and visible in the UMC.

krbtgt and Guest should likely also be marked as hidden?
Comment 3 Stefan Gohmann univentionstaff 2013-10-22 16:23:46 CEST
(In reply to Moritz Muehlenhoff from comment #2)
> On a fresh installation the dns-master user is still present and visible in
> the UMC.

The amd64 dvd build was not finished.

> krbtgt and Guest should likely also be marked as hidden?

These are default AD users.
Comment 4 Stefan Gohmann univentionstaff 2013-10-29 06:13:42 CET
r45656:

* Don't hide the dns-* users by default because the DRS replication
  took in most cases about five minutes which increases the
  installation time too much compared to the benefit. Wait for Bug
  #30115 (Bug #32871)
Comment 5 Lukas Walter univentionstaff 2013-10-29 17:46:31 CET
All mentioned objects are hidden.
Comment 6 Stefan Gohmann univentionstaff 2013-11-19 06:44:01 CET
UCS 3.2 has been released:
 http://docs.univention.de/release-notes-3.2-en.html
 http://docs.univention.de/release-notes-3.2-de.html

If this error occurs again, please use "Clone This Bug".
Comment 7 Stefan Gohmann univentionstaff 2013-12-06 07:25:28 CET
*** Bug 31042 has been marked as a duplicate of this bug. ***