Bug 33529 - cron.daily mails harmless logrotate errors to admin
cron.daily mails harmless logrotate errors to admin
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Samba
UCS 3.2
amd64 Linux
: P5 minor (vote)
: UCS 3.2-0-errata
Assigned To: Felix Botner
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-21 23:31 CET by Gerard Kok
Modified: 2013-12-12 11:29 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerard Kok 2013-11-21 23:31:41 CET
After upgrading my 3.1 UCS test server to 3.2, I'm getting messages with the following content in my mailbox:

/etc/cron.daily/logrotate:
error: univention-samba4:38 duplicate log entry for /var/log/samba/log.smbd
error: found error in /var/log/samba/log.smbd , skipping
error: univention-samba4:49 duplicate log entry for /var/log/samba/log.nmbd
error: found error in /var/log/samba/log.nmbd , skipping
error: winbind:1 duplicate log entry for /var/log/samba/log.winbindd
error: found error in /var/log/samba/log.winbindd , skipping

I think this is caused by /var/log/samba/log.smbd, /var/log/samba/log.nmbd and /var/log/samba/log.winbindd being configured to be logrotated in two files: /etc/logrotate.d/samba and /etc/logrotate.d/univention-samba4 (for log.smbd and log.nmbd), and /etc/logrotate.d/winbindd and /etc/logrotate.d/univention-samba4 (for log.winbindd). I suppose the bug can be solved by removing one of the logrotate configurations for each file.
Comment 1 Ingo Steuwer univentionstaff 2013-11-22 09:19:35 CET
I can confirm that, the very same error mail on a UCS DC Master installed with UCS 3.1/Samba4 and updated to UCS 3.2.
Comment 2 Felix Botner univentionstaff 2013-12-02 16:37:35 CET
/etc/logrotate.d/samba and /etc/logrotate.d/winbind are config templates of univention-samba4 with the appropriate settings.

-> logrotate -f /etc/logrotate.conf

runs fine after the Update

YAML: errata/2013-11-20-univention-samba4.yaml
univention-samba4: 3.0.39-6.562.201312021513
Comment 3 Arvid Requate univentionstaff 2013-12-09 16:03:41 CET
Ok:
 * logrotate.d subfiles shipped by samba are now diverted and replaced by UCR templates
 * Advisory is ok.
Comment 4 Moritz Muehlenhoff univentionstaff 2013-12-12 11:29:51 CET
http://errata.univention.de/ucs/3.2/6.html