Bug 33531 - Compatibility issues with pxelinux.0 in UCS 3.1
Compatibility issues with pxelinux.0 in UCS 3.1
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 3.1
Other Linux
: P5 normal (vote)
: UCS 3.2-2-errata
Assigned To: Philipp Hahn
Janek Walkenhorst
:
Depends on: 33063
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-22 08:54 CET by Stefan Gohmann
Modified: 2014-08-07 17:46 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-11-22 08:54:43 CET
Erratum for UCS 3.2

+++ This bug was initially created as a clone of Bug #33063 +++

[Ticket#2013102821002257]

A customer reported boot loops of clients receiving a "local boot" order via PXE after upgrading to UCS 3.1 (syslinux-common 4.02).
A downgrade of the pxelinux.0 file to the version shipped with UCS 2.4 solved the problems.
Upgrading to pxelinux.0 from syslinux-common 4.05 works only for some of the "problem devices".
Comment 1 Philipp Hahn univentionstaff 2014-01-29 18:54:45 CET
As LOCALBOOT depends on the BIOS, this method has many known problems: <http://www.syslinux.org/wiki/index.php/Hardware_Compatibility#LOCALBOOT>
At least one work-around for AMI-BIOS was added: syslinux-3.85-pre9-5-ga68e106
The changelog states:
+       * PXELINUX: disable a hack that would make localboot work on
+         some machines, but break just about as many.  Some machines
+         which worked with "localboot 0" in previous versions may
+         need "localboot -1" in this one.  If you have a machine
+         which requires "localboot -1", a copy of the dmidecode
+         or sysdump output would be appreciated.
That "LOCALBOOT -1" was added in syslinux-4.00-pre30-2-ge19346b and forces the use of "INT 18h" for local boot.

LOCALBOOT supports other optional parameter: <http://www.syslinux.org/wiki/index.php/SYSLINUX#LOCALBOOT_type_.5BISOLINUX.2C_PXELINUX.5D>

In newer versions of syslinux the LOCALBOOT functionality was re-factured into its own module: syslinux-3.80-pre4

There are too may "Fujitsu-Notebooks" and "Dell-Notebooks", so we probably should make it configurable. Best through an UMC-policy, as different BIOSes might require different work-arounds, like the "chain.c32 hd0" trick mentioned above.
Comment 2 Philipp Hahn univentionstaff 2014-07-15 10:46:02 CEST
LOCALBOOT works again with 6.02, but since 5.10 TFTP is abyssal slow:
            3MB Kernel  72MB InitRD
4.0x, 5.01: 1s          30s
5.10..6.02: 43s         16m

More details in <http://bladis/zaQ9bFxSMN>
Comment 3 Philipp Hahn univentionstaff 2014-07-28 14:28:05 CEST
Syslinux-3.72 has been re-imported as the "syslinux3" source package in errata3.2-2, as any newer version either has problems with LOCALBOOT or TFTP with the Dell E6510.

The source package builds the two binary packages "syslinux3" and "syslinux3-common", which conflict with the packages "syslinx" and "syslinux-common" included in UCS-3 by default: Only one set may be installed in parallel so that /var/lib/univention-client-boot/pxelinux.0 always points to the correct /usr/lib/syslinux/pxelinux.0 file.

The following FTBFS bug <https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505136> had to be fixed, as the compiler in UCS-3 is more picky about the old syslinux version.
NO_WERROR=1 had to be added for building gpxe.

syslinux3_3.71+dfsg-5.1.201407281355
ucs-3.2-2/doc/errata/staging/2014-07-28-syslinux3.yaml (r52279)
Comment 4 Janek Walkenhorst univentionstaff 2014-08-07 14:17:56 CEST
Installation of syslinux3 replaces syslinux.
Boot works.
Advisory: OK (Typo fixed)
Comment 5 Janek Walkenhorst univentionstaff 2014-08-07 16:41:10 CEST
The packages syslinux3 and syslinx3-common were added to the 3.2-3 trigger list.
Comment 6 Janek Walkenhorst univentionstaff 2014-08-07 17:46:53 CEST
http://errata.univention.de/ucs/3.2/168.html