Bug 33567 - Change ou / cn name from upper- to lowercase not possible
Change ou / cn name from upper- to lowercase not possible
Status: RESOLVED DUPLICATE of bug 33482
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 3.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: UMC maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-26 09:43 CET by Stefan Gohmann
Modified: 2018-04-13 13:30 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2013-11-26 09:43:16 CET
In UCS it is not possible to change a ou name (or container name) from lower to upper case and vice versa.

root@master191:~# udm container/ou create --set name="ou-test1"
Object created: ou=ou-test1,LDAP_BASE
root@master191:~# udm container/ou create --set name="ou-test2" --position ou=ou-test1,LDAP_BASE
Object created: ou=ou-test2,ou=ou-test1,LDAP_BASE
root@master191:~# udm container/ou modify --dn ou=ou-test1,LDAP_BASE --set name=OU-Test1
LDAP Error: Moving not possible: old and new DN are identical.
root@master191:~# ldapmodrdn -x -D cn=admin,$(ucr get ldap/base) -w $(</etc/ldap.secret) ou=ou-test1,LDAP_BASE ou=OU-Test1 -r
Rename Result: Operation not allowed on non-leaf (66)
Additional info: subtree rename not supported
root@master191:~# 

A rename via Samba 4 is possible which results in a connector reject:

root@master191:~# ldbrename -H /var/lib//samba/private/sam.ldb "OU=ou-test1,LDAP_BASE" "OU=OU-Test1,LDAP_BASE"
Renamed 1 record
root@master191:~#
Comment 1 Stefan Gohmann univentionstaff 2013-11-26 09:44:27 CET
One possible solution would be the move in three steps, from ou-test1 to an temporary object and than to OU-Test1.
Comment 2 Dirk Wiesenthal univentionstaff 2013-12-11 14:42:45 CET

*** This bug has been marked as a duplicate of bug 33482 ***