Bug 33725 - Renaming usernames may fail when only changing upper/lower case
Renaming usernames may fail when only changing upper/lower case
Status: RESOLVED DUPLICATE of bug 28230
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: UMC maintainers
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-11 13:51 CET by Dirk Wiesenthal
Modified: 2013-12-11 14:42 CET (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2013-12-11 13:51:41 CET
When changing the username of a user, the DN changes. So "editing" a user in such a way is more a "move".

When checking for already existing usernames, the old name is found, which differs in case, e.g.
  uid=Administrator - change to uid=administrator
    -> search for administrator
      -> find Administrator; reject change!

Also holds for groups/group and computers/computer
Comment 1 Dirk Wiesenthal univentionstaff 2013-12-11 14:42:01 CET

*** This bug has been marked as a duplicate of bug 28230 ***