Bug 33890 - Configurable default Administrator name in univention-ldap
Configurable default Administrator name in univention-ldap
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: LDAP
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-0-errata
Assigned To: Arvid Requate
Stefan Gohmann
:
: 25782 33735 (view as bug list)
Depends on: 33893
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-09 18:32 CET by Arvid Requate
Modified: 2017-06-19 19:30 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Internationalization
Max CVSS v3 score:
requate: Patch_Available+


Attachments
custom_Administrator_univention-ldap.patch (9.83 KB, patch)
2014-01-09 18:32 CET, Arvid Requate
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Arvid Requate univentionstaff 2014-01-09 18:32:49 CET
Created attachment 5721 [details]
custom_Administrator_univention-ldap.patch

The name of the role account "Administrator" should be configurable.


+++ This bug was initially created as a clone of Bug #33645 +++

See Bug #33644

univention-ldap should consider the different names.
Comment 1 Arvid Requate univentionstaff 2014-01-14 16:39:43 CET
*** Bug 33735 has been marked as a duplicate of this bug. ***
Comment 2 Arvid Requate univentionstaff 2014-01-14 17:25:34 CET
The package has been adjusted accordingly and built in the scope errata3.2-0.

It also adds a script to /usr/lib/univention-pam/well-known-sid-name-mapping.d
which is called by the postrun function of the "well-known-sid-name-mapping" listener in case a UCR mapping was modified (Bug 33897). The script initiates a graceful-reload of the OpenLDAP server.

Advisory: 2013-12-19-univention-ldap.yaml
Comment 3 Stefan Gohmann univentionstaff 2014-01-22 09:01:16 CET
Code: OK
YAML: Failed: The YAML file contains hints for the Administrator user but not for the group settings.
Test cases: OK
Comment 4 Arvid Requate univentionstaff 2014-01-22 16:25:43 CET
The group settings is covered already in http://errata.univention.de/ucs/3.2/13.html .

Adjusted for Bug 33897.
Advisory updated.
Comment 5 Stefan Gohmann univentionstaff 2014-01-23 07:20:17 CET
OK
Comment 6 Moritz Muehlenhoff univentionstaff 2014-01-29 11:19:16 CET
http://errata.univention.de/ucs/3.2/37.html
Comment 7 Arvid Requate univentionstaff 2017-06-19 19:28:55 CEST
*** Bug 25782 has been marked as a duplicate of this bug. ***