Bug 34071 - iframe is too small for login form
iframe is too small for login form
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-4-errata
Assigned To: Alexander Kläser
Florian Best
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-07 12:30 CET by Sönke Schwardt-Krummrich
Modified: 2014-12-17 12:55 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Browser compatibility, Design, Usability
Max CVSS v3 score:


Attachments
Login form (24.99 KB, image/png)
2014-02-07 12:31 CET, Sönke Schwardt-Krummrich
Details
Screenshot of login dialogue with scrollbars (69.61 KB, image/png)
2014-06-12 10:38 CEST, Alexander Kläser
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sönke Schwardt-Krummrich univentionstaff 2014-02-07 12:30:28 CET
The UMC login button is not fully visible with Firefox 27.
Comment 1 Sönke Schwardt-Krummrich univentionstaff 2014-02-07 12:31:04 CET
Created attachment 5783 [details]
Login form
Comment 2 Florian Best univentionstaff 2014-04-11 16:54:48 CEST
I cannot really reproduce this in my own Firefox 27. I saw that this is reliable reproducible on Sönkes Firefox.
Comment 3 Alexander Kläser univentionstaff 2014-04-24 11:23:48 CEST
(In reply to Florian Best from comment #2)
> I cannot really reproduce this in my own Firefox 27. I saw that this is
> reliable reproducible on Sönkes Firefox.

Neither can I when navigation to demo.univention.de in my FF 28.
Comment 4 Florian Best univentionstaff 2014-06-11 10:06:24 CEST
Sönke, this has maybe to do with some add-ons / extensions you added to firefox?
Comment 5 Sönke Schwardt-Krummrich univentionstaff 2014-06-11 11:30:28 CEST
(In reply to Florian Best from comment #4)
> Sönke, this has maybe to do with some add-ons / extensions you added to
> firefox?

Just retested with FF30 and no extensions/addons → the problem does still exist
Comment 6 Alexander Kläser univentionstaff 2014-06-12 10:38:09 CEST
Created attachment 5953 [details]
Screenshot of login dialogue with scrollbars

I also observed a scrollbar in the iframe (see attached screenshot):

> <body class="umc" style="overflow-y: scroll;">
> ...

This only happens after the session expires.

The problem with the half visible button could be circumvented by using a CSS footer:

> http://stackoverflow.com/a/15893575/3116268
Comment 7 Alexander Kläser univentionstaff 2014-07-09 13:27:58 CEST
The problem seems to be related to the line-height property. Fixing it to 1.2em seems to already help. Only the vertical positioning of text on green buttons needs to be fixed, AFAIS.

> http://stackoverflow.com/questions/21530908/bigger-height-in-firefox-than-in-chrome
Comment 8 Florian Best univentionstaff 2014-12-11 13:02:51 CET
Fixed in:
univention-management-console-frontend 3.0.152-46.974.201412111255
2014-12-10-univention-management-console-frontend.yaml
Comment 9 Alexander Kläser univentionstaff 2014-12-11 17:32:02 CET
The button is still cut, setting the height of the CSS class .umcLoginDialogFormContainer to 18em instead of 17.5em seems to improve this. Not sure about other browsers, though.
Comment 10 Alexander Kläser univentionstaff 2014-12-16 13:56:16 CET
I adjusted the margin-top a little bit. Looks fine now in FF + Chromium.

univention-management-console-frontend (3.0.153-5):
* Bug #34071: Fine adjustment of appearance for login button
Comment 11 Florian Best univentionstaff 2014-12-16 15:19:14 CET
OK: looks good in FF, chromium, IE9
YAML: Ok, (version number updated)
Comment 12 Moritz Muehlenhoff univentionstaff 2014-12-17 12:55:11 CET
http://errata.univention.de/ucs/3.2/249.html