Bug 34253 - ucslint doesn't accept "${@}"
ucslint doesn't accept "${@}"
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: ucslint
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 4.1-2-errata
Assigned To: Philipp Hahn
Florian Best
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-05 10:56 CET by Jan Christoph Ebersbach
Modified: 2016-06-22 14:21 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Christoph Ebersbach univentionstaff 2014-03-05 10:56:01 CET
I had the following line my a join script:

  	udm shares/share modify "${@}" --dn "${dn_opsi_depot}" ...

ucslint complained that $@ isn't present, although it is:

  E:0001-2: 99joinscript.inst: join script contains 1 lines with missing "$@"
Comment 1 Philipp Hahn univentionstaff 2016-06-17 15:25:17 CEST
r70321 | Bug #34253 ucslint: Check for ${@}

Package: ucslint
Version: 5.0.3-5.79.201606171517
Branch: ucs_4.1-0
Scope: errata4.1-2

r70324 | Bug #41603,Bug #38853,Bug #34253: ucslint YAML
 ucslint.yaml
Comment 2 Florian Best univentionstaff 2016-06-21 13:48:47 CEST
OK: fix
OK: YAML
Comment 3 Janek Walkenhorst univentionstaff 2016-06-22 14:21:39 CEST
<http://errata.software-univention.de/ucs/4.1/204.html>