Bug 34266 - UDM uses cn=univention for moving objects
UDM uses cn=univention for moving objects
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-1-errata
Assigned To: Stefan Gohmann
Dirk Wiesenthal
:
Depends on: 33482
Blocks: 33566
  Show dependency treegraph
 
Reported: 2014-03-06 07:34 CET by Stefan Gohmann
Modified: 2014-04-22 11:06 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
don't use cn=univention for moving objects (817 bytes, patch)
2014-03-06 07:34 CET, Stefan Gohmann
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-03-06 07:34:22 CET
Created attachment 5816 [details]
don't use cn=univention for moving objects

Ticket #2014012921002092

We move the temporary objects to cn=univention. This will be ignored by the S4 connector and the S4 connector does not recognize the move. 

+++ This bug was initially created as a clone of Bug #33482 +++

I've creates ou=users,ou=MSWATT,<base> containing some users and an empty ou=NoWatt,<base>. With RSAT tools I moved ou=users,ou=MSWATT,<base> to ou=NoWatt,<base>:

20.11.2013 10:45:05,663 LDAP        (PROCESS): sync to ucs:   [            ou] [      move] OU=users,ou=nowatt,dc=testing,dc=tim
20.11.2013 10:45:05,737 LDAP        (ERROR  ): Unknown Exception during sync_to_ucs
20.11.2013 10:45:05,759 LDAP        (ERROR  ): Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/univention/s4connector/__init__.py", line 1306, in sync_to_ucs
    result = self.move_in_ucs(property_type, object, module, position)
  File "/usr/lib/pymodules/python2.6/univention/s4connector/__init__.py", line 1196, in move_in_ucs
    ucs_object.move(object['dn'])
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 396, in move
    subobject.move(subnewdn)
  File "/usr/lib/pymodules/python2.6/univention/admin/handlers/__init__.py", line 358, in move
    raise univention.admin.uexceptions.ldapError, _('Moving not possible: old and new DN are identical.')
ldapError: Moving not possible: old and new DN are identical.
Comment 1 Stefan Gohmann univentionstaff 2014-04-15 15:20:43 CEST
Fixed with r49367. YAML r49368
Comment 2 Stefan Gohmann univentionstaff 2014-04-15 15:20:59 CEST
(In reply to Stefan Gohmann from comment #1)
> Fixed with r49367. YAML r49368
Comment 3 Dirk Wiesenthal univentionstaff 2014-04-16 14:39:03 CEST
Unable to reproduce the bug, but the description sounds reasonable and the fix does not break anything.

YAML slightly updated.
Comment 4 Moritz Muehlenhoff univentionstaff 2014-04-22 11:06:03 CEST
http://errata.univention.de/ucs/3.2/97.html