Bug 34360 - UMC setup wizard for UCC
UMC setup wizard for UCC
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: UCS Integration
unspecified
Other Linux
: P5 enhancement
: UCC 2.0
Assigned To: Alexander Kläser
Moritz Muehlenhoff
: interim-4
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-18 13:25 CET by Moritz Muehlenhoff
Modified: 2014-06-12 09:19 CEST (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2014-03-18 13:25:15 CET
There should be a wizard which guides the user through the initial setup of a UCC installation after UCC has been installed through the App Center.

A first outline of the menus is kept in doku/trunk/intern/ucc/umc-module
Comment 1 Moritz Muehlenhoff univentionstaff 2014-04-25 13:46:55 CEST
Initial work available for the beta release, move to interim-3 for finishing.
Comment 2 Moritz Muehlenhoff univentionstaff 2014-04-29 12:52:09 CEST
A feedback function at the end would be nice
Comment 3 Alexander Kläser univentionstaff 2014-05-13 19:42:45 CEST
Added download functionality, progress bar and error handling.

ucc-umc-setup (0.1.11-1):
* Bug #34360: added progress and error handling
Comment 4 Alexander Kläser univentionstaff 2014-05-14 19:24:30 CEST
Installation of Citrix Receiver in the UCC image has been completed. Note that the ucc-image-add-citrix-receiver has been extended with a --progress option.


ucc-umc-setup (0.1.13-1):
* Bug #34360: added postinst, parse progress information from stdout of
  ucc-image-add-citrix-receiver

ucc-umc-setup (0.1.12-1):
* Bug #34360: added installation of citrix receiver package


ucc-image-toolkit (2.0.14-1):
* Bug #34360: flush stdout for progress information

ucc-image-toolkit (2.0.13-1):
* Bug #34360: add parsable progress output to ucc-image-add-citrix-receiver
Comment 5 Alexander Kläser univentionstaff 2014-05-15 18:38:17 CEST
Update, see changelog entry below...

ucc-umc-setup (0.1.14-1):
* display currently set values in the wizard
* dynamically hide download pages if images are already present
* store Citrix Receiver deb  package file in the UCC image directory
Comment 6 Alexander Kläser univentionstaff 2014-05-16 17:11:01 CEST
Remaining TODO:
* Translation
* Add UCRV ucc/image/defaultid/{thinclient,desktop}
* Error handling for network configuration
* Adjust the confirmation page and add the total size to be downloaded
Comment 7 Alexander Kläser univentionstaff 2014-05-16 23:38:51 CEST
(In reply to Alexander Kläser from comment #6)
> Remaining TODO:
> * Translation
> * Add UCRV ucc/image/defaultid/{thinclient,desktop}
> * Error handling for network configuration
> * Adjust the confirmation page and add the total size to be downloaded

Fixed. Left over TODO → translation.


ucc-umc-setup (0.1.15-1):
Bug #34360:
* added UCR variables ucc/image/defaultid/{thinclient,desktop}
* improved error handling for network configuration
* adjusted the presentation of the confirmation page
Comment 8 Alexander Kläser univentionstaff 2014-05-19 11:36:33 CEST
The following problems have been fixed:
* Errors were masked (e.g., when not enough space is left on the hard disk while unxzing).
* The auto login checkbox for Citrix was initially unchecked..


ucc-umc-setup (0.1.16-1):
* Bug #34360: make sure that errors are not masked
Comment 9 Alexander Kläser univentionstaff 2014-05-19 12:21:14 CEST
The following problems have been addressed:
* The ucc_software policy "xrdp-terminalserver-installation" is now created (without referencing it at a container). 
* Problems when creating a new policy and referencing them at a container have been resolved.


ucc-umc-setup (0.1.18-1):
* Bug #34360: do not reference xrdp installation policy

ucc-umc-setup (0.1.17-1):
Bug #34360:
* create ucc_software policy for installation of xrdp
* create first the policy object and then reference it at a given container
Comment 10 Moritz Muehlenhoff univentionstaff 2014-05-19 14:16:15 CEST
(In reply to Alexander Kläser from comment #9)
> The following problems have been addressed:
> * Problems when creating a new policy and referencing them at a container
> have been resolved.

That's working fine now.
Comment 11 Alexander Kläser univentionstaff 2014-05-19 14:37:48 CEST
The decompress method now ensures during decompressing that at least 0.5 GB of free space is left on the hard disk.


ucc-image-toolkit (2.0.17-1):
* Bug #34360: regularly check for enough free size (> 0.5 GB) on hard disk
  while decompressing an .xz file
Comment 12 Alexander Kläser univentionstaff 2014-05-19 16:18:39 CEST
> Execution of command 'uccsetup/progress' has failed:
>  
> Traceback (most recent call last):
>   ...
>   File "/usr/lib/pymodules/python2.6/ucc/images.py", line 176, in _unxz
>     raise IOError(_('Not enough space left on hard disk.') % outfile)
> TypeError: not all arguments converted during string formatting

Typo has been fixed in


ucc-image-toolkit (2.0.18-1):
* Bug #34360: fixed typo
Comment 13 Moritz Muehlenhoff univentionstaff 2014-05-20 07:41:23 CEST
(In reply to Alexander Kläser from comment #11)
> The decompress method now ensures during decompressing that at least 0.5 GB
> of free space is left on the hard disk.
> 
> 
> ucc-image-toolkit (2.0.17-1):
> * Bug #34360: regularly check for enough free size (> 0.5 GB) on hard disk
>   while decompressing an .xz file

Ok, this is now properly handled. When downloading on a system with sufficient diskspace to download the image, but not extract it get the following error message:

----------------
Image data of spec file ucc-2.0-rc-desktop-image.img.xz.spec could not be downloaded from server:
Decompression of file /var/lib/univention-client-boot/ucc-2.0-rc-desktop-image.img.xz failed: Not enough space left on hard disk.!
----------------
Comment 14 Moritz Muehlenhoff univentionstaff 2014-05-20 10:10:35 CEST
(In reply to Alexander Kläser from comment #8)
> * The auto login checkbox for Citrix was initially unchecked..

Confirmed to be fixed in the current version.
Comment 15 Moritz Muehlenhoff univentionstaff 2014-05-20 10:13:33 CEST
The following configuration modes have been successfully tested:

- Deployment of Linux desktops
- Configuration of thin client access to a website
- Configuration of thin client access to Citrix (the Citrix setup is currently broken, but everything up to the login worked fine)

Still pending with open issues:
- RDP
- XRDP terminal server
Comment 16 Alexander Kläser univentionstaff 2014-05-20 12:08:16 CEST
(In reply to Moritz Muehlenhoff from comment #15)
> The following configuration modes have been successfully tested:
> 
> - Deployment of Linux desktops
> - Configuration of thin client access to a website
> - Configuration of thin client access to Citrix (the Citrix setup is
> currently broken, but everything up to the login worked fine)
> 
> Still pending with open issues:
> - RDP
> - XRDP terminal server

I have adjusted the policy paths and referencing containers:
* The policy ucc-usersession is not created anymore, instead the corresponding default-settings is used (and referenced at the LDAP base). The policy default-settings has already been used before and is created in the join scripts.
* The installation policy xrdp-terminalserver-installation is now referenced at cn=ucc-xrdpserver,cn=computers,... (the container is created in the join scripts)
* All policies are now stored in cn=ucc,cn=policies,...


ucc-umc-setup (0.1.19-1):
* Bug #34360: adjust policy names/paths and the referencing containers

ucc-management-integration (2.0.10-1):
* Bug #34360: create the container ucc-xrdpserver in the join script
Comment 17 Moritz Muehlenhoff univentionstaff 2014-05-20 13:12:05 CEST
(In reply to Alexander Kläser from comment #16)

> I have adjusted the policy paths and referencing containers:
> * The policy ucc-usersession is not created anymore, instead the
> corresponding default-settings is used (and referenced at the LDAP base).
> The policy default-settings has already been used before and is created in
> the join scripts.

That is working fine.
Comment 18 Moritz Muehlenhoff univentionstaff 2014-05-21 09:08:14 CEST
RDP setup and XRDP setup have been successfully tested as well. From my POV the only thing missing is the i18n.
Comment 19 Alexander Kläser univentionstaff 2014-05-22 15:17:29 CEST
All translations have been added. The upload page is now always displayed and only the upload widgets are hidden in case Citrix Receiver has been uploaded before. The link to the UDM computer module (on the last page) has been adjusted according to the server type - i.e., if UDM is not available on the system the text refers the reader to the DC master system of the domain (just textual, no link). Some example URLs have been added and a logic error in the JavaScript code has been fixed (related to the initial setup of the widgets).


ucc-umc-setup (0.1.22-1):
* Bug #34360: added missing translations

ucc-umc-setup (0.1.21-1):
Bug #34360:
* fixed typo in the logic of the JavaScript code
* always show the upload page for Citrix Receiver, only hide upload widgets
* added example URLs
* adjust link to UDM computer module depending on system type
Comment 20 Alexander Kläser univentionstaff 2014-05-22 17:25:24 CEST
ucc-umc-setup (0.1.23-1):
Bug #34360:
* allow to overwrite already downloaded Citrix Receiver file
* adjust jshint remarks
* adapted translations
Comment 21 Moritz Muehlenhoff univentionstaff 2014-05-23 07:59:16 CEST
See mail with changes needed for texts and translation
Comment 22 Moritz Muehlenhoff univentionstaff 2014-05-23 08:29:15 CEST
* always show the upload page for Citrix Receiver, only hide upload widgets
* added example URLs
* allow to overwrite already downloaded Citrix Receiver file

These are working fine now, so the only thing left is the update of the text and i18n.
Comment 23 Alexander Kläser univentionstaff 2014-05-23 16:24:05 CEST
Fixed missing translations.
Also the entry "downloaded image" on the upload page for Citrix Receiver is now only visible if the download option for the UCC thin client image has been chosen. (If no image is available, a warning message is prompted.)


ucc-umc-setup (0.1.25-1):
* Bug #34360: only show the 'downloaded image' entry on citrix page if
  download has been selected

ucc-umc-setup (0.1.24-1):
* Bug #34360: updated translations
Comment 24 Alexander Kläser univentionstaff 2014-05-23 19:31:53 CEST
I just noticed that the initial upload of Citrix Receiver had not been enforced due to previous adaptations. Fixed.


ucc-umc-setup (0.1.26-1):
* Bug #34360: make sure that Citrix Receiver needs to be uploaded initially
Comment 25 Moritz Muehlenhoff univentionstaff 2014-05-26 08:03:21 CEST
The UCC setup module cannot be opened on a DC slave.
Comment 26 Alexander Kläser univentionstaff 2014-05-26 10:28:45 CEST
(In reply to Moritz Muehlenhoff from comment #25)
> The UCC setup module cannot be opened on a DC slave.

Fixed.

ucc-umc-setup (0.1.27-1):
* Bug #34360: fixed handling of non DC master systems in JavaScript, added
  keywords in .xml file
Comment 27 Alexander Kläser univentionstaff 2014-05-26 10:48:32 CEST
A typo fix...

ucc-umc-setup (0.1.28-1):
* Bug #34360: fixed HTML typo in German translation on the last wizard page
Comment 28 Moritz Muehlenhoff univentionstaff 2014-05-26 12:59:51 CEST
(In reply to Alexander Kläser from comment #26)

> ucc-umc-setup (0.1.27-1):
> * Bug #34360: fixed handling of non DC master systems in JavaScript, added
>   keywords in .xml file

That has been fixed.
Comment 29 Alexander Kläser univentionstaff 2014-05-26 14:08:12 CEST
ucc-umc-setup (0.1.29-1):
* Bug #34360: removed deprecated static entry for UCC images
Comment 30 Moritz Muehlenhoff univentionstaff 2014-05-26 14:50:50 CEST
(In reply to Alexander Kläser from comment #23)
> Fixed missing translations.
> Also the entry "downloaded image" on the upload page for Citrix Receiver is
> now only visible if the download option for the UCC thin client image has
> been chosen. (If no image is available, a warning message is prompted.)

That is working fine now. The missing i18n has been added as well.
Comment 31 Moritz Muehlenhoff univentionstaff 2014-05-27 11:52:55 CEST
The wizard doesn't work on a member server.
Comment 32 Moritz Muehlenhoff univentionstaff 2014-05-27 13:59:18 CEST
It also fails on a UCS@school slave DC (different traceback)
Comment 33 Alexander Kläser univentionstaff 2014-05-27 15:53:29 CEST
(In reply to Moritz Muehlenhoff from comment #31)
> The wizard doesn't work on a member server.

My fault, the handling of guessing the correct LDAP host was wrong. Now ldap/server/name as well as ldap/server/additional are being evaluated.

ucc-umc-setup (0.1.30-1):
* Bug #34360: make sure that the correct LDAP server is used on non DCs


(In reply to Moritz Muehlenhoff from comment #32)
> It also fails on a UCS@school slave DC (different traceback)

appcenter.test.software-univention.de needs to be registered as App Center server on the master. In this scenario, UCC1 has been installed on the master.
Comment 34 Moritz Muehlenhoff univentionstaff 2014-05-28 09:42:56 CEST
(In reply to Alexander Kläser from comment #33)
> (In reply to Moritz Muehlenhoff from comment #31)
> > The wizard doesn't work on a member server.
> 
> My fault, the handling of guessing the correct LDAP host was wrong. Now
> ldap/server/name as well as ldap/server/additional are being evaluated.
> 
> ucc-umc-setup (0.1.30-1):
> * Bug #34360: make sure that the correct LDAP server is used on non DCs

That is working fine now (tested on a member server and on a DC slave)

> (In reply to Moritz Muehlenhoff from comment #32)
> > It also fails on a UCS@school slave DC (different traceback)
> 
> appcenter.test.software-univention.de needs to be registered as App Center
> server on the master. In this scenario, UCC1 has been installed on the
> master.

Indeed, that was an error in my test setup. It now works fine in the corrected installation.
Comment 35 Alexander Kläser univentionstaff 2014-05-30 02:15:26 CEST
Some adaptations of the wizard text.

ucc-umc-setup (0.1.31-1):
* Bug #34360: simplify wizard text
Comment 36 Moritz Muehlenhoff univentionstaff 2014-05-30 09:31:00 CEST
I've made two additional changes to the PO file, otherwise fine!
Comment 37 Moritz Muehlenhoff univentionstaff 2014-06-12 09:19:32 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".