Bug 34367 - Infinite loading animation after changing password
Infinite loading animation after changing password
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - User settings
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-1-errata
Assigned To: Dirk Wiesenthal
Lukas Walter
:
: 34532 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-03-19 08:32 CET by Tim Petersen
Modified: 2014-04-16 16:12 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tim Petersen univentionstaff 2014-03-19 08:32:51 CET
Ticket #2014031821007514

If you change a user password in umc (via udm-self view) in module umd you'll get a popup that password change was successfull. After that you'll get anb infinite loading animation and nothing happends. A reload afterwards seems to be sufficient to reload the module.

The reload should be done automatically after confirming the popup dialogue!
Comment 1 Dirk Wiesenthal univentionstaff 2014-04-04 00:31:31 CEST
Fixed in
  univention-management-console-module-udm 4.0.97-20.444.201404040008

A managed Deferred was not resolved() by hand. Probably a regression caused by the large code changes for UDM wizards. The reload was done, but the standby just did not go away.
Comment 2 Lukas Walter univentionstaff 2014-04-04 15:25:29 CEST
OK: Problem reproduced in old version
OK: Fixed in new version
OK: YAML
Comment 3 Dirk Wiesenthal univentionstaff 2014-04-10 23:36:37 CEST
*** Bug 34532 has been marked as a duplicate of this bug. ***
Comment 4 Moritz Muehlenhoff univentionstaff 2014-04-16 16:12:32 CEST
http://errata.univention.de/ucs/3.2/92.html