Bug 34437 - Provide/Install {intel,amd64}-microcode packages
Provide/Install {intel,amd64}-microcode packages
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Kernel
UCS 3.2
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Philipp Hahn
Stefan Gohmann
: interim-3
Depends on: 35370
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-01 16:53 CEST by Janis Meybohm
Modified: 2014-11-26 06:54 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2014-04-01 16:53:07 CEST
We should provide (and probably install by default) intel and amd microcode packages:
Comment 1 Philipp Hahn univentionstaff 2014-10-09 16:24:03 CEST
repo_admin.py -U -r 4.0-0-0 -d jessie -p iucode-tool # 1.1-1
repo_admin.py -U -r 4.0-0-0 -d jessie -p intel-microcode # 
2.20140624.1
repo_admin.py -U -r 4.0-0-0 -d jessie -p amd64-microcode # 2.20131007.1+really20130710.1

Package: amd64-microcode
Version: 2.20131007.1+really20130710.1.1.201410091440
Branch: ucs_4.0-0

Package: iucode-tool
Version: 1.1-1.1.201410091448
Branch: ucs_4.0-0

Package: intel-microcode
Version: 2.20140624.1.2.201410091455
Branch: ucs_4.0-0

r54278 | Bug #34437 Kernel: Recommend CPU microcode updates
 univention-kernel-image recommends {amd64,intel}-microcode

Package: univention-kernel-image
Version: 8.0.3-1.62.201410091501
Branch: ucs_4.0-0

r54279 | Bug #34437 Kernel: Recommend CPU microcode updates
 The packages <package>amd64-microcode</package> and <package>intel-microcode</package> were added and are installed by default to provide micro-code updates for AMD and Intel CPUs

<http://jenkins.knut.univention.de:8080/job/UCS-4.0/job/UCS-4.0-0/job/Release%20Notes/39/artifact/webroot/release-notes-4.0-0-en.html#changelog:basic:kernel>


FYI: When installing the following error/warning is printed:
> update-initramfs: Generating /boot/initrd.img-3.16-ucs82-amd64
> /usr/share/initramfs-tools/hooks/intel_microcode: 136: /usr/share/initramfs-tools/hooks/intel_microcode: prepend_earlyinitramfs: not found
> E: intel-microcode: failed to prepend early firmware to initramfs
> W: intel-microcode: will try to use late initramfs update mode...

This is caused by initramfs-tools being to old: UCS-4.0 contained 0.112~bpo70+1, but we need 0.115. No changelog for that specific issue as this is handled by Bug #35370.
<https://bugs.launchpad.net/ubuntu/+source/intel-microcode/+bug/1194370>

r13831 | Drop patches for initramfs-tools_0.115~bpo70+1

Package: initramfs-tools
Version: 0.115~bpo70+1.35.201410091545
Branch: ucs_4.0-0

$ isoinfo -f -R -i ucs_4.0-0-20141009-155552-dvd-amd64.iso|egrep 'initramfs|microcode|iucode'
/all/initramfs-tools_0.115~bpo70+1.35.201410091545_all.deb
/amd64/amd64-microcode_2.20131007.1+really20130710.1.1.201410091440_amd64.deb
/amd64/intel-microcode_2.20140624.1.2.201410091455_amd64.deb
/amd64/iucode-tool_1.1-1.1.201410091448_amd64.deb
/firmware/amd64-microcode_2.20131007.1+really20130710.1.1.201410091440_amd64.deb
/firmware/intel-microcode_2.20140624.1.2.201410091455_amd64.deb
Comment 2 Stefan Gohmann univentionstaff 2014-11-04 13:18:15 CET
OK, packages are installed.

Changelog: OK
Comment 3 Stefan Gohmann univentionstaff 2014-11-26 06:54:13 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".