Bug 34452 - Update for Citrix Receiver 13 / Simplify installation
Update for Citrix Receiver 13 / Simplify installation
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Terminal services
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Moritz Muehlenhoff
Felix Botner
: interim-3
: 34486 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-03 15:17 CEST by Moritz Muehlenhoff
Modified: 2014-06-12 09:19 CEST (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Moritz Muehlenhoff univentionstaff 2014-04-03 15:17:33 CEST
Current Citrix Receiver is 13. 

The installation of the Citrix should be simplified.
Comment 1 Moritz Muehlenhoff univentionstaff 2014-04-07 12:56:27 CEST
*** Bug 34486 has been marked as a duplicate of this bug. ***
Comment 2 Moritz Muehlenhoff univentionstaff 2014-04-22 11:48:27 CEST
A new tool has been created which integrates the Citrix Receiver into a UCC image; the necessary dependencies are installed and the Receiver installed afterwards. It is part of ucc-image-toolkit

This works on both i386 and amd64 UCS systems.

On the command line the following command can be issued (but this tool will mostly be executed from the UCC setup wizard in the UMC):

ucc-image-add-citrix-receiver --uccimage ucc-2.0-alpha3-thinclient-image.img 
--debpackage icaclient_13.0.0.256735_i386.deb

The hash values are recomputed at the end.

Logging is made to /var/log/univention/citrix-install.log



The EULA is no longer accepted as part of the installation process, but on a per user basis. univention-ucc-session-xenapp has been extended to handle the new UCR variable citrix/accepteula. If activated, the EULA doesn't need to be acknowledged. This setting is also configured as part of the UCC UMC wizard.
Comment 3 Moritz Muehlenhoff univentionstaff 2014-04-22 12:33:01 CEST
Changelog commited to SVN.
Comment 4 Felix Botner univentionstaff 2014-04-28 17:19:27 CEST
(In reply to Moritz Muehlenhoff from comment #2)
> A new tool has been created which integrates the Citrix Receiver into a UCC
> image; the necessary dependencies are installed and the Receiver installed
> afterwards. It is part of ucc-image-toolkit
> 
> This works on both i386 and amd64 UCS systems.
> 
> On the command line the following command can be issued (but this tool will
> mostly be executed from the UCC setup wizard in the UMC):
> 
> ucc-image-add-citrix-receiver --uccimage ucc-2.0-alpha3-thinclient-image.img 
> --debpackage icaclient_13.0.0.256735_i386.deb

OK 

> 
> The hash values are recomputed at the end.

OK

> 
> Logging is made to /var/log/univention/citrix-install.log

OK 
 
> The EULA is no longer accepted as part of the installation process, but on a
> per user basis. univention-ucc-session-xenapp has been extended to handle
> the new UCR variable citrix/accepteula. If activated, the EULA doesn't need
> to be acknowledged. This setting is also configured as part of the UCC UMC
> wizard.

OK

some minor issues:

(1)
Why 
 if "cmd('mounnt...') == 2: log("Mounting the image failed...
and not 
 if "cmd('mounnt...') != 0: log("Mounting the image failed...

(2) 
better 
 mount -o loop /var/lib/univention-client-boot/' + basename(opt.image)
instead of mount -o loop /var/lib/univention-client-boot/' + opt.image

(3)
better not delete de ica deb file
Comment 5 Moritz Muehlenhoff univentionstaff 2014-04-29 11:34:23 CEST
> some minor issues:
> 
> (1)
> Why 
>  if "cmd('mounnt...') == 2: log("Mounting the image failed...
> and not 
>  if "cmd('mounnt...') != 0: log("Mounting the image failed...

Fixed.

 
> (2) 
> better 
>  mount -o loop /var/lib/univention-client-boot/' + basename(opt.image)
> instead of mount -o loop /var/lib/univention-client-boot/' + opt.image

Fixed.
 
> (3)
> better not delete de ica deb file

You're right, I removed that. This was intended for the UCC wizatrd, where it's all handled "behind the scenes", but for execution by a user the file should not be removed.

-> SVN revision 49692
Comment 6 Felix Botner univentionstaff 2014-05-07 10:37:17 CEST
OK
Comment 7 Moritz Muehlenhoff univentionstaff 2014-06-12 09:19:32 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".