Bug 34517 - Include more translation packages
Include more translation packages
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Image management
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Moritz Muehlenhoff
Erik Damrose
: interim-2
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-09 16:48 CEST by Erik Damrose
Modified: 2014-06-12 09:20 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2014-04-09 16:48:28 CEST
After installing the current UCC 2 development desktop image, the user is greeted by a new KDE feature each time after logging in: A popup informs that additional language packs can be installed.

A normal user cannot install these herself.

The packages that are installed are hyphen-de libreoffice-help-de mythes-de thunderbird-locale-de
We should decide if we want to somehow disable that functionality or install all these packages for all languages that are available.
Comment 1 Moritz Muehlenhoff univentionstaff 2014-04-10 08:55:53 CEST
We should check whether there a bugs for the languagepack packages, maybe the dependencies get fixed before the 14.04 release. Otherwise we should include the packages (plus their fr, es and nl variants) in the desktop image.
Comment 2 Moritz Muehlenhoff univentionstaff 2014-04-14 10:47:15 CEST
A new source package univention-ucc-i18n has been created which builds these binary packages:

univention-ucc-i18n-fr - UCC - Translations and localisations for the French desktop image
univention-ucc-i18n-en - UCC - Translations and localisations for the English desktop image
univention-ucc-i18n-de - UCC - Translations and localisations for the German desktop image
univention-ucc-i18n-es - UCC - Translations and localisations for the Spanish desktop image
univention-ucc-i18n-nl - UCC - Translations and localisations for the Dutch desktop image


They install the dependencies for the currently supported languages (some packages don't exist in some languages, e.g. no hyphen-nl package exists). This allows better customisation for already installed packages than only adding them to the default configurations. I've adapted the default configurations to use the new meta packages.
Comment 3 Erik Damrose univentionstaff 2014-04-14 17:03:53 CEST
Verified: Package dependencies are OK, no popup about missing language packs.
Comment 4 Moritz Muehlenhoff univentionstaff 2014-06-12 09:20:02 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".