Bug 34612 - added boot option for partition script
added boot option for partition script
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: initrd
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Felix Botner
Moritz Muehlenhoff
: interim-2
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-04-23 15:04 CEST by Felix Botner
Modified: 2014-10-01 09:12 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2014-04-23 15:04:46 CEST
We need to add a boot option to define the partition script. Also this script should be copied from the nfs boot server in the initrd before partitioning.

This would help to separate the partitioning from the image.
Comment 1 Moritz Muehlenhoff univentionstaff 2014-04-23 15:06:35 CEST
(In reply to Felix Botner from comment #0)
> We need to add a boot option to define the partition script. Also this
> script should be copied from the nfs boot server in the initrd before
> partitioning.
> 
> This would help to separate the partitioning from the image.
Comment 2 Felix Botner univentionstaff 2014-04-24 11:18:22 CEST
Added boot option partition_script=FILE. If this option is set the ucc initrd looks for the file in /var/lib/univention-client-boot/partition-scripts on the boot server (via nfsmount) and uses this script for partitioning instead of the partitioning settings from the image.

A sample script is shipped with ucc-pxe-boot -> /var/lib/univention-client-boot/partition-scripts/custom_partition.example

QA: please test this for PXE boot and local boot
Comment 3 Moritz Muehlenhoff univentionstaff 2014-04-28 13:57:16 CEST
I could successfully rollout a desktop system using an encrypted hard disk by using partition_script=desktop_encrypted.example
Comment 4 Moritz Muehlenhoff univentionstaff 2014-06-12 09:19:44 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".
Comment 5 Erik Damrose univentionstaff 2014-10-01 09:12:57 CEST
*** Bug 34774 has been marked as a duplicate of this bug. ***