Bug 34814 - Startup regression: Delays with plymouth and lightdm
Startup regression: Delays with plymouth and lightdm
Status: CLOSED FIXED
Product: Univention Corporate Client (UCC)
Classification: Unclassified
Component: Image Desktop
unspecified
Other Linux
: P5 normal
: UCC 2.0
Assigned To: Erik Damrose
Moritz Muehlenhoff
: interim-3
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-12 17:38 CEST by Erik Damrose
Modified: 2014-06-12 09:19 CEST (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2014-05-12 17:38:08 CEST
There is a noticable delay during startup while switching from plymouth to lightdm. During this time, a black login tty is visible. We should check init/upstart dependencies.
Comment 1 Erik Damrose univentionstaff 2014-05-19 09:39:50 CEST
See also Bug #31126, which changed upstart dependencies
Comment 2 Erik Damrose univentionstaff 2014-05-21 14:53:55 CEST
I changed the dependencies of the involved upstart jobs:
ucc-update does not stop plymouth anymore
plymouth-stop stops plymouth, but waits for lightdm to be start_ed_ (was: start_ing_) and does not trigger on runlevel changes

r50509 univention-corporate-client 2.0.3-1
r50510 changelog
Comment 3 Moritz Muehlenhoff univentionstaff 2014-05-22 10:16:13 CEST
Tested successfully with the desktop and thin client image:

There is no longer tty output visible when switching between fbdev and LightDM/X11. There's still a black screen for about a second, but that's an unavoidable hardware limitation.

I also tested the installation of an additional package using a UCC software policy (since that's what introduced the new behaviour) and everything was fine as well.
Comment 4 Moritz Muehlenhoff univentionstaff 2014-06-12 09:19:55 CEST
UCC 2.0 has been released:
 http://docs.univention.de/release-notes-ucc-2.0.html

If this error occurs again, please use "Clone This Bug".