Bug 34873 - allow configuration of slapd.conf limits via ucr
allow configuration of slapd.conf limits via ucr
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: LDAP
UNSTABLE
Other Linux
: P5 enhancement (vote)
: UCS 4.1-3-errata
Assigned To: Felix Botner
Stefan Gohmann
:
: 41429 41647 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-05-20 11:02 CEST by Felix Botner
Modified: 2016-09-07 18:41 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Forked for project
Max CVSS v3 score:
best: Patch_Available+


Attachments
slapd-limits.patch (2.73 KB, patch)
2014-06-13 13:48 CEST, Felix Botner
Details | Diff
slapd-limits.patch (2.65 KB, patch)
2014-06-13 15:33 CEST, Felix Botner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2014-05-20 11:02:52 CEST
The current slapd template does not allow to configure the "limits" option

/etc/univention/templates/files/etc/ldap/slapd.conf.d/40univention-ldap-server_database:
  limits users time.soft=-1 time.hard=-1

We need an ucr var for limits (e.g. to configure pagedResults searchs -> limits users time.soft=-1 time.hard=-1 size.pr=50 size.prtotal=unlimited).
Comment 1 Felix Botner univentionstaff 2014-06-13 13:48:00 CEST
Created attachment 5957 [details]
slapd-limits.patch
Comment 2 Felix Botner univentionstaff 2014-06-13 15:33:09 CEST
Created attachment 5959 [details]
slapd-limits.patch
Comment 3 Michel Smidt univentionstaff 2016-06-06 13:27:39 CEST
*** Bug 41429 has been marked as a duplicate of this bug. ***
Comment 4 Felix Botner univentionstaff 2016-08-22 18:23:40 CEST
*** Bug 41647 has been marked as a duplicate of this bug. ***
Comment 5 Felix Botner univentionstaff 2016-08-24 09:38:59 CEST
Added UCR ldap/limits (; separated list of limit options)

-> ucr set ucr set ldap/limits='group/univentionGroup/uniqueMember="cn=Domain Admins,cn=groups,o=XY,o=ZZ" size.soft=2000 size.hard=5000;users time.soft=-1 time.hard=-1'

-> more /etc/ldap/slapd.conf | grep limits
limits group/univentionGroup/uniqueMember="cn=Domain Admins,cn=groups,o=XY,o=ZZ" size.soft=2000 size.hard=5000
limits users time.soft=-1 time.hard=-1

univention-ldap.yaml
merged to 4.2
Comment 6 Stefan Gohmann univentionstaff 2016-09-07 06:29:15 CEST
Code review: OK

ucs-test: OK

Tests: OK

YAML: OK (small adjustment r72334)
Comment 7 Janek Walkenhorst univentionstaff 2016-09-07 18:41:33 CEST
<http://errata.software-univention.de/ucs/4.1/249.html>