Bug 35170 - replace replication.py initialization with slapadd
replace replication.py initialization with slapadd
Status: VERIFIED DUPLICATE of bug 40514
Product: UCS
Classification: Unclassified
Component: Listener (univention-directory-listener)
UCS 3.2
Other Linux
: P5 normal (vote)
: ---
Assigned To: Philipp Hahn
Felix Botner
:
Depends on:
Blocks: 40514
  Show dependency treegraph
 
Reported: 2014-06-19 17:36 CEST by Felix Botner
Modified: 2016-07-22 10:09 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
fake_replication_init.patch (10.14 KB, patch)
2014-06-19 17:38 CEST, Felix Botner
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2014-06-19 17:36:13 CEST
We need a way to replace the replication.py initialization (in the directory listener) with a simple slapadd.
Comment 1 Felix Botner univentionstaff 2014-06-19 17:38:54 CEST
Created attachment 5965 [details]
fake_replication_init.patch

PoC

(1) added -P (initialize handlers only, but not from scratch) to listener, see bug #35165

(2) added fake replication.py initialization to join script 03univention-directory-listener.inst

If the system is not a DC master, the new join script fakes the replication.py initialization (echo 3 > /var/lib/univention-directory-listener/handlers/replication) gets notifier and ldif from master (ldap paged results search), updates the local ldap with the ldif file (slapdd), sets the notifier_id and then the listener is started with -P (instead of -i) for the initialization phase.
Optinal, the notifier_id, the ldif file and the listener cache file can be pre-configured.

    listener/join/notifier/id -> notifier id
    listener/join/ldif/file -> ldif file to use (instead of ldap search)
    listener/join/cache/file -> listener cache (replaces /var/lib/univention-directory-listener/cache.db)
Comment 2 Philipp Hahn univentionstaff 2016-07-19 09:15:39 CEST

*** This bug has been marked as a duplicate of bug 40514 ***