Bug 35178 - Kernel OOPS while rebooting a Xen VM in xen_netbk_rx_action
Kernel OOPS while rebooting a Xen VM in xen_netbk_rx_action
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Kernel
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-2-errata
Assigned To: Moritz Muehlenhoff
Philipp Hahn
:
Depends on:
Blocks: 35826
  Show dependency treegraph
 
Reported: 2014-06-23 12:25 CEST by Erik Damrose
Modified: 2014-09-04 14:42 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Patch which prevents the Kernel OOPS (1.97 KB, patch)
2014-07-01 12:38 CEST, Erik Damrose
Details | Diff
xen-netback: skip pending packets in unmapped ring (7.08 KB, patch)
2014-07-02 09:42 CEST, Philipp Hahn
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Erik Damrose univentionstaff 2014-06-23 12:25:40 CEST
A customer reported a kernel OOPS on the Xen Host while rebooting a Xen VM (2014052521004965).

The Xen Host is running kernel 3.10.0-ucs58-amd64

The error is caused by the xen netback subsystem. More information and a preliminary patch, which seems to fix the problem in the customer environment, is available on the xen-devel list: http://lists.xenproject.org/archives/html/xen-devel/2014-06/msg00818.html
Comment 1 Moritz Muehlenhoff univentionstaff 2014-06-24 08:55:48 CEST
Once a final patch is merged into Linux git, please send it to stable tree so that it ends up in a future 3.10.x release:
https://www.kernel.org/doc/Documentation/stable_kernel_rules.txt
Comment 2 Erik Damrose univentionstaff 2014-07-01 12:38:34 CEST
Created attachment 5981 [details]
Patch which prevents the Kernel OOPS

The original patch was slightly refined: The skb which would cause the error is now properly discarded if the virtual interface is no longer mapped.
Comment 3 Moritz Muehlenhoff univentionstaff 2014-07-01 12:59:42 CEST
Will be added along with Bug 34751
Comment 4 Philipp Hahn univentionstaff 2014-07-02 09:42:22 CEST
Created attachment 5983 [details]
xen-netback: skip pending packets in unmapped ring

GIT patch for Xen and Linux Kernel ML
Comment 5 Moritz Muehlenhoff univentionstaff 2014-07-02 11:00:50 CEST
The patch from comment 2 was integrated and folded into the Linux errata updates from Bug 34751:

YAML files: 2014-07-01-linux.yaml and 2014-07-01-univention-kernel-image.yaml
Comment 6 Philipp Hahn univentionstaff 2014-07-03 16:30:39 CEST
OK: /usr/sbin/announce_errata -V 2014-07-01-linux.yaml
OK: /usr/sbin/announce_errata -V 2014-07-01-univention-kernel-image.yaml
OK: aptitude install '?source-package(univention-kernel-image)?installed'
OK: diff objdump -Sle /lib/modules/*ucs[56]8*/kerel/drivers/net/xen-netback/xen-netback.ko
OK: grep UniDEBUG /lib/modules/3.10.0-ucs?8-amd64/kernel/drivers/net/xen-netback/xen-netback.ko
OK: Xen network test