Bug 35261 - Don't leave object in listener cache if a listener module fails
Don't leave object in listener cache if a listener module fails
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Listener (univention-directory-listener)
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-2-errata
Assigned To: Philipp Hahn
Stefan Gohmann
:
Depends on:
Blocks: 35168
  Show dependency treegraph
 
Reported: 2014-07-04 13:45 CEST by Janis Meybohm
Modified: 2015-01-06 08:46 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2014-07-04 13:45:58 CEST
If a join script failes (on delete) the object is left in the cache. If an object with the same DN is added afterwards the cache entry is found (old entryUUID) and the object is then considered as "not existent" on master ldap.
Comment 1 Philipp Hahn univentionstaff 2014-07-04 19:22:45 CEST
(In reply to Janis Meybohm from comment #0)
> If a [-join script- -> +listener module+] failes ...

After a removal by UUID a second run using the DN is performed.

The cache entry is now also deleted even when a listener module fails.

staging/2014-07-04-univention-directory-listener.yaml

r51538 | Bug #35261 Listener: Retry update after delete by UUID [YAML]
r51537 | Bug #35261 Listener: Retry update after delete by UUID

PS: As previously the unit tests in doc.34355/ do run find if the S4C is disbaled!
Comment 2 Stefan Gohmann univentionstaff 2014-07-08 08:14:58 CEST
YAML: OK

Code: OK (Although I don't really like the new goto handling in change.c)

ucs-test: OK: http://jenkins.knut.univention.de:8080/view/Autotest/job/UCS%203.2-2%20Autotest%20MultiEnv/69/

Tests: OK
I was able to reproduce it. I put a raise in the nss.py listener module and created and deleted group objects. The problem is fixed with the new version.
Comment 3 Moritz Muehlenhoff univentionstaff 2014-07-08 16:13:13 CEST
http://errata.univention.de/ucs/3.2/136.html