Bug 35358 - Migrate heimdal patches to UCS 4.0
Migrate heimdal patches to UCS 4.0
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Kerberos
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Arvid Requate
Stefan Gohmann
: interim-2
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-15 08:34 CEST by Stefan Gohmann
Modified: 2014-11-26 06:55 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-07-15 08:34:01 CEST
The heimdal patches should be migrate to UCS 4.
Comment 1 Arvid Requate univentionstaff 2014-08-13 20:43:10 CEST
Patches have been copied from errata3.2-1, adjusted to python2.7 and debian 3.0 (quilt) patch policy.

Another upstream patch was required to fix http://kerberos.996246.n3.nabble.com/Problem-compiling-cups-against-heimdal-1-6-td38582.html . 

Leaving this open, maybe we pull a more recent upstream package (Debian is currently at 1.6~rc2 with a more recent upstream snapshot. Probably we should check the upstream changes carefully).

A multi-arch patch was required as well for the debian/*.install files (1.6~rc2 has this), so even if we don't go for the upstream packages we should check the recent debian packages for relevant Debian patches.
Comment 2 Stefan Gohmann univentionstaff 2014-08-20 09:12:21 CEST
Move to interim-2
Comment 3 Arvid Requate univentionstaff 2014-08-26 13:21:40 CEST
Ok, checked https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=732342 , this doesn't affect us. In the heimdal version we currrently have the bug is not in yet and in the next one it has been fixed already, so there is no need for the adjusted package dependencies introduced by Debian packaging ( http://anonscm.debian.org/gitweb/?p=pkg-samba/samba.git;a=commitdiff;h=5b2ba2b ).

Changelog adjusted.
Comment 4 Stefan Gohmann univentionstaff 2014-09-30 06:41:04 CEST
Code review: Question:
 * You have removed python-univention-lib from the dependency list. Any particular reason?

ucs-test: No kerberos specific test case failed → OK

Changelog: OK
Comment 5 Arvid Requate univentionstaff 2014-10-06 11:48:23 CEST
> * You have removed python-univention-lib from the dependency list. Any particular reason?

No, thanks for checking, fixed.
Comment 6 Stefan Gohmann univentionstaff 2014-10-06 12:13:04 CEST
(In reply to Arvid Requate from comment #5)
> > * You have removed python-univention-lib from the dependency list. Any particular reason?
> 
> No, thanks for checking, fixed.

OK
Comment 7 Stefan Gohmann univentionstaff 2014-11-26 06:55:24 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".