Bug 35407 - Grid columns not sortable in specific circumstances
Grid columns not sortable in specific circumstances
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 4.1-1-errata
Assigned To: Florian Best
Jürn Brodersen
:
: 36047 40837 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-18 10:11 CEST by Florian Best
Modified: 2016-03-18 06:44 CET (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
best: Patch_Available+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Best univentionstaff 2014-07-18 10:11:48 CEST
Error in tools.cmpObjects if one of the objects to compare is null instead of a String.
This error causes that in UCS@school e.g. the column 'Class' in the Users wizard is not sortable so that one get the error message "Es ist ein Fehler aufgetreten" in the grid instead of grid entries.

Exception: TypeError: Cannot read property 'toLowerCase' of null

Fix is simply:
Index: umc/tools.js
===================================================================
--- umc/tools.js	(Revision 51947)
+++ umc/tools.js	(Arbeitskopie)
 -969,7 +969,7 @@
 					// check for lowercase
 					var a = _a[o.attr];
 					var b = _b[o.attr];
-					if (o.ignCase && a.toLowerCase && b.toLowerCase) {
+					if (o.ignCase && a && a.toLowerCase && b && b.toLowerCase) {
 						a = a.toLowerCase();
 						b = b.toLowerCase();
 					}
Comment 1 Florian Best univentionstaff 2014-10-06 10:01:09 CEST
*** Bug 36047 has been marked as a duplicate of this bug. ***
Comment 2 Michel Smidt univentionstaff 2016-03-06 21:31:26 CET
Reported by customer on #2016022321000671.
Comment 3 Florian Best univentionstaff 2016-03-07 10:45:25 CET
*** Bug 40837 has been marked as a duplicate of this bug. ***
Comment 4 Florian Best univentionstaff 2016-03-07 10:51:35 CET
Fixed.

univention-management-console-frontend.yaml:
r67952 | YAML Bug #35407 Bug #40613

univention-management-console-frontend (5.0.63-29):
r67951 | Bug #35407: fixed a typo in umc.tools.cmpObjects which caused that in some situations e.g. the grid header weren't sortable
Comment 5 Jürn Brodersen univentionstaff 2016-03-14 17:36:01 CET
What I tested:
Sorted classes by description in schoolwizards/classes.
-> Sorting by description is now possible.

Changes: OK.
YAML: OK.

→ VERIFIED
Comment 6 Florian Best univentionstaff 2016-03-18 06:44:50 CET
<http://errata.software-univention.de/ucs/4.1/132.html>