Bug 35425 - UVMM for UCS-4.0
UVMM for UCS-4.0
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Virtualization - UVMM
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Philipp Hahn
Drees Dormann
https://hutten.knut.univention.de/med...
: interim-1
: 35361 (view as bug list)
Depends on:
Blocks: 35428
  Show dependency treegraph
 
Reported: 2014-07-21 16:05 CEST by Philipp Hahn
Modified: 2014-11-26 06:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
univention-virtual-machine-manageer-node-kvm error (154.05 KB, image/jpeg)
2014-08-28 16:22 CEST, Drees Dormann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-07-21 16:05:22 CEST
univention-virtual-machine-manager-daemon
univention-virtual-machine-manager-node # kvm
(univention-novnc)
Comment 1 Philipp Hahn univentionstaff 2014-07-22 09:19:10 CEST
r52015 | Bug #35425: clone UVMM for UCS-4.0-0
r52016 | Bug #35425: Clone UVMM-node for UCS-4.0-0
r52024 | Bug #35425: Clone noVNC for UCS-4.0-0
r52026 | Bug #35425 UVMM: UCS-4.0 version bump

univention-virtual-machine-manager-node-common_3.0.0-1.80.201407220904
univention-virtual-machine-manager-daemon_4.0.0-1.499.201407220912
univention-novnc_0.4+0+20131014+git142aa45-5.6.201407220920
Comment 2 Florian Best univentionstaff 2014-07-22 10:20:25 CEST
virtualization/univention-novnc/debian/univention-novnc.univention-service
5:programs=/usr/bin/python2.6 /usr/share/novnc/utils/websockify
→ uses python2.6
Comment 3 Philipp Hahn univentionstaff 2014-07-22 10:34:24 CEST
r52034 | Bug #35425 noVNC: Fix python2.7 usage
univention-novnc_0.4+0+20131014+git142aa45-6.7.201407221032
Comment 4 Stefan Gohmann univentionstaff 2014-08-20 08:06:47 CEST
*** Bug 35361 has been marked as a duplicate of this bug. ***
Comment 5 Stefan Gohmann univentionstaff 2014-08-25 08:32:49 CEST
I've added a changelog for all migrated packages: r52983
Comment 6 Drees Dormann univentionstaff 2014-08-28 16:22:38 CEST
Created attachment 6080 [details]
univention-virtual-machine-manageer-node-kvm error

univention-virtual-machine-manager-daemon installs ok 
univention-novnc installs ok

upon installing univention-virtual-machine-manager-node-kvm
an error occurs (see attached screenshot) and server is not reachable via network anymore
by setting ucr uvmm/kvm/bridge/autostart=manual eth0 and rebooting the server is accessible again
Comment 7 Philipp Hahn univentionstaff 2014-08-29 08:59:48 CEST
Running a KVM server with DHCP-client enabled is insane: For KVM we copied the Xen behavior to rename the physical interface "ethX" to "pethX", which allows us to create a bridge with that name "eth0" instead. As "dhclient" is still using the old name "eth0", it is now confused as the interface was renamed to "peth0" behind its back, leading to the network failure.
Long-term the rename-script should be removed.
For now I strongly recommend to reboot the server after installing KVM (or Xen) because of the network-bridge-dance.
Comment 8 Philipp Hahn univentionstaff 2014-08-29 09:57:11 CEST
(In reply to Philipp Hahn from comment #7)
> Long-term the rename-script should be removed.

That's Bug #33694.
Comment 9 Philipp Hahn univentionstaff 2014-08-29 14:10:43 CEST
FYI: post-installing u-v-m-n-kvm worked for me even with DHCP-client.
RFC: What was the exact setup you were testing?
Comment 10 Drees Dormann univentionstaff 2014-09-01 15:28:03 CEST
it is working now.
i was using xen2 for testing, no other modules installed.
Comment 11 Stefan Gohmann univentionstaff 2014-11-26 06:54:20 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".