Bug 35499 - Revise layout and graphics of UMC appliance wizard for responsive design
Revise layout and graphics of UMC appliance wizard for responsive design
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - Basic settings
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Dirk Wiesenthal
Alexander Kläser
: interim-3
: 35772 36520 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-28 15:54 CEST by Philipp Hahn
Modified: 2014-11-26 06:54 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Design
Max CVSS v3 score:


Attachments
Screenshots + svg graphic files (534.41 KB, application/x-gzip)
2014-10-13 15:48 CEST, Alexander Kläser
Details
Final SVG graphic files (550.00 KB, application/x-gzip)
2014-10-17 19:04 CEST, Alexander Kläser
Details
error icon (10.24 KB, image/svg+xml)
2014-10-21 15:33 CEST, Alexander Kläser
Details
umc-system-setup.png (30.89 KB, image/png)
2014-10-28 06:43 CET, Stefan Gohmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-07-28 15:54:28 CEST
The d-i only support 800x600, as 1024x768 requires 1½ MB Video-RAM, which is not available for example with Citrix.
Comment 1 Alexander Kläser univentionstaff 2014-07-28 22:36:23 CEST
UMC for UCS4 aims at working nicely for different resolutions.
Comment 2 Alexander Kläser univentionstaff 2014-10-13 15:48:09 CEST
Created attachment 6161 [details]
Screenshots + svg graphic files

@Dirk: As discussed I will attach all necessary information + graphics for the adaptation of the wizard.

I spotted 4 pages for which we currently have not yet the graphic files:
* Page for admin account information (when creating a new UCS domain)
* Page for domain admin credentials (when joining a UCS or AD domain)
* Warning page when configuring a base system
... these graphics will be provided later on.
The current graphics might also be changed again after the next revision.

For 800x600, we probably need a special tweak (w.r.t. the Bootstrap CSS classes) for the Page, as the layout of side navigation + main container are changed at a window with of 991px. A possible solution could be similar to the property "bootstrapClasses" in umc/widgets/GalleryPane, then for umc/widgets/Page and both for "nav" and "main" containers. For small resolutions, the graphics can also be scaled down to match the dimensions of the screen.

By default the page header text will displayed in the "nav" container. Not sure whether an adaptation here is necessary in order to meet the design in the supplied screenshots.
Comment 3 Alexander Kläser univentionstaff 2014-10-13 15:49:21 CEST
@Dirk: See comment above.
Comment 4 Alexander Kläser univentionstaff 2014-10-17 19:04:49 CEST
Created attachment 6189 [details]
Final SVG graphic files

I attached the final .svg graphic files that should be included on the different pages as follows:

  welcome → welcome.svg
  locale → locale.svg
  network → network.svg
  role → domain.svg
  role-nonmaster-ad → domain.svg
  credentials-master → account.svg 
  credentials-ad → credentials.svg
  credentials-nonmaster → credentials.svg
  warning-basesystem → domain.svg
  fqdn-master → fqdn.svg
  fqdn-nonmaster-all → fqdn.svg
  software → software.svg
  validation → error.svg
  summary → summary.svg
  error → error.svg
  done → done.svg
Comment 5 Alexander Kläser univentionstaff 2014-10-21 15:33:24 CEST
Created attachment 6196 [details]
error icon

Updated error icon file
Comment 6 Stefan Gohmann univentionstaff 2014-10-22 09:59:47 CEST
*** Bug 35772 has been marked as a duplicate of this bug. ***
Comment 7 Dirk Wiesenthal univentionstaff 2014-10-22 14:36:05 CEST
Graphics have been added. Adjusted some margins etc. to better fit to 800x600
Comment 8 Stefan Gohmann univentionstaff 2014-10-28 06:43:58 CET
Created attachment 6248 [details]
umc-system-setup.png

That looks really good. See attached screenshot. I think we should expand the fields for FQDN and LDAP base and put one below the other.
Comment 9 Dirk Wiesenthal univentionstaff 2014-10-31 01:52:05 CET
Fixed in
  univention-system-setup 8.1.34-3.741.201410310033
Comment 10 Alexander Kläser univentionstaff 2014-11-05 16:16:15 CET
Love it :) !
Changelog entry not really necessary, but OK.
VERIFIED.
Comment 11 Alexander Kläser univentionstaff 2014-11-07 14:49:44 CET
*** Bug 36520 has been marked as a duplicate of this bug. ***
Comment 12 Stefan Gohmann univentionstaff 2014-11-26 06:54:05 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".