Bug 35661 - must_have_no_conflicts_apps tests for any conflicting package
must_have_no_conflicts_apps tests for any conflicting package
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 4.0-1-errata
Assigned To: Dirk Wiesenthal
Florian Best
:
Depends on:
Blocks: 38220
  Show dependency treegraph
 
Reported: 2014-08-20 12:19 CEST by Janis Meybohm
Modified: 2015-04-09 09:49 CEST (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Janis Meybohm univentionstaff 2014-08-20 12:19:45 CEST
must_have_no_conflicts_apps tests if any package in defaultpackages of a conflicting app is installed

 if any(package_manager.is_installed(package) for package in app.get('defaultpackages')):
    ...

This is somehow wrong in situations where different apps share some default packages (like owncloud5 and owncloud6 do) leading to false positive conflict detection like described in http://forum.univention.de/viewtopic.php?t=3417:
Zarafa Update is blocked because of installed owncloud5 but zarafa app only has a conflict with owncloud6.


One may change toe test from any() to all() to avoid this but this may break other conflicts that depend on any() like:

samba-memberserver conflicts with samba4 => ['univention-samba4', 'univention-s4-connector']
samba3 conflicts with samba4 => ['univention-samba4', 'univention-s4-connector']
Comment 1 Dirk Wiesenthal univentionstaff 2015-03-24 14:26:53 CET
Fixed in
  univention-management-console-module-appcenter 4.1.20-18.326.201503241422

Also added a ucs-test
Comment 2 Dirk Wiesenthal univentionstaff 2015-03-24 14:29:52 CET
Should be / can be backported to UCS 3.2.

No apps in 4.0 do have this issue. This was 3.2 specific (Zarafa -> ownCloud 6)
Comment 3 Florian Best univentionstaff 2015-03-24 15:13:41 CET
OK: all packages have to be installed to be a conflicted app
OK: Code-Review
OK: test (reproduces the error)
OK: YAML
Comment 4 Janek Walkenhorst univentionstaff 2015-03-25 16:37:23 CET
<http://errata.univention.de/ucs/4.0/120.html>