Bug 35672 - mailAlternativeAddress readonly when "synced"
mailAlternativeAddress readonly when "synced"
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UDM (Generic)
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-3-errata
Assigned To: Stefan Gohmann
Felix Botner
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-08-21 09:07 CEST by Dirk Ahrnke
Modified: 2014-09-10 17:39 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Ahrnke 2014-08-21 09:07:08 CEST
Since the introduction of the "AD Member" mode it is not possible to edit mailAlternativeAddress via UMC or udm-cli when the object is synced from Active Directory.

This is caused by the setting "readonly_when_synced=1" for mailAlternativeAddress in /usr/share/pyshared/univention/admin/handlers/users/user.py (package python-univention-directory-manager).

As there seems to be no mechanism where any of the AD-attributes is mapped to mailAlternativeAddress, there is no reason to lock the attribute for a synced object.
Comment 1 Stefan Gohmann univentionstaff 2014-09-02 09:22:39 CEST
readonly_when_synced has been set to 0 for mailAlternativeAddress. It will be announced for 3.2-2-errata and 3.2-3-errata.

UCS 3.2-3-errata: r53218
UCS 4.0: r53219
YAML: r53220
Comment 2 Felix Botner univentionstaff 2014-09-03 10:19:32 CEST
OK - errata3.2-3
OK - 4.0

OK - YAML
Comment 3 Janek Walkenhorst univentionstaff 2014-09-10 17:39:54 CEST
http://errata.univention.de/ucs/3.2/197.html