Bug 35687 - simplejson → json
simplejson → json
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.4
Other Linux
: P5 enhancement (vote)
: UCS 4.4-0-errata
Assigned To: Florian Best
Julia Bremer
:
: 49053 (view as bug list)
Depends on:
Blocks: 49053
  Show dependency treegraph
 
Reported: 2014-08-22 08:51 CEST by Philipp Hahn
Modified: 2019-03-27 14:08 CET (History)
3 users (show)

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional): Cleanup
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-08-22 08:51:29 CEST
Since 2.6 Python has a built-in "json" module, no need to use the external "simplejson".
We should cleanup our source and convert from "simplejson" to "json".
<https://docs.python.org/2.6/library/json.html>
Comment 1 Florian Best univentionstaff 2014-08-22 08:53:35 CEST
I somewhere created a bug which already suggests this for UMC. because simplejson is broken code (encoding things, str/unicode mixes).
Comment 2 Florian Best univentionstaff 2019-03-13 14:00:32 CET
base/univention-system-activation/debian/control: python-simplejson,
base/univention-system-setup/debian/control: python-simplejson,
management/univention-management-console/src/univention/management/console/protocol/message.py:»   import simplejson as json

The last dependency of it is in univention-system-setup while the UMC still uses it.
Comment 3 Florian Best univentionstaff 2019-03-14 08:25:50 CET
The last use/dependencies of simplejson have been removed.

univention-system-activation (4.0.0-2)
426f19abb1f6 | Bug #35687: replace simplejson with json

univention-management-console (11.0.4-7)
70df97a76a80 | Bug #35687: replace simplejson with json

univention-system-setup (12.0.2-4)
8d7e3e5c3585 | Bug #35687: replace simplejson with json
Comment 4 Julia Bremer univentionstaff 2019-03-14 11:03:56 CET
Verified

Code-Review OK, minimal changes were made
Comment 6 Florian Best univentionstaff 2019-03-27 14:08:12 CET
*** Bug 49053 has been marked as a duplicate of this bug. ***