Bug 35688 - Disable dependency based init script ordering (insserv ) for UCS-4
Disable dependency based init script ordering (insserv ) for UCS-4
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: General
UCS 4.0
All Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Philipp Hahn
Stefan Gohmann
: interim-2
: 35684 (view as bug list)
Depends on: 22507 22566 35651
Blocks: 44924
  Show dependency treegraph
 
Reported: 2014-08-22 09:08 CEST by Philipp Hahn
Modified: 2017-07-03 17:07 CEST (History)
3 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philipp Hahn univentionstaff 2014-08-22 09:08:02 CEST
+++ This bug was initially created as a clone of Bug #22507 +++
+++ This bug was initially created as a clone of Bug #22506 +++

Many init scripts are still missing the LSB headers, especially out UCS scripts. Therefore we need to disable the use of insserv for now.

We need to decide if
1. we keep disabling insserv,
2. or add the missing LSB headers,
3. wait for systemd; then we have to convert our init scripts to unit files anyway and can add proper dependencies.
Comment 1 Philipp Hahn univentionstaff 2014-08-22 10:32:04 CEST
r13470: Port 3.1 patches
 Disable insserv
 Plymouth fixes

Package: sysvinit
Version: 2.88dsf-41.43.201408220944
Branch: ucs_4.0-0
Comment 2 Stefan Gohmann univentionstaff 2014-08-22 11:29:28 CEST
*** Bug 35684 has been marked as a duplicate of this bug. ***
Comment 3 Philipp Hahn univentionstaff 2014-09-12 10:55:28 CEST
we keep disabling insserv and wait for the switch-over to systemd (or what-ever).
Comment 4 Stefan Gohmann univentionstaff 2014-09-30 16:26:28 CEST
Changelog: I've added the bug number: r54071

Tests: OK

Code review: failed: You have added 4.0-0-0-ucs/2.88dsf-41+deb7u1/series. Is it needed?
Comment 5 Philipp Hahn univentionstaff 2014-09-30 16:28:58 CEST
r13776 | Remove quilt series file
Comment 6 Stefan Gohmann univentionstaff 2014-09-30 16:53:04 CEST
(In reply to Philipp Hahn from comment #5)
> r13776 | Remove quilt series file

OK
Comment 7 Stefan Gohmann univentionstaff 2014-11-26 06:55:40 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".