Bug 35757 - Domain check is case sensitive in connection wizard
Domain check is case sensitive in connection wizard
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - AD Connector
UCS 3.2
Other Linux
: P5 normal (vote)
: UCS 3.2-3-errata
Assigned To: Stefan Gohmann
Arvid Requate
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-01 07:02 CEST by Stefan Gohmann
Modified: 2014-09-10 17:35 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-09-01 07:02:47 CEST
We got the feedback that a tester was unable to configure the AD connection wizard because UCS converts the domain into lower case and the testers domain is upper case:
 Windows domain: SPRINGFIELD.local
 UCS domain:     springfield.local

UCS should ignore the case.

Ticket #2014083021000104
Comment 1 Arvid Requate univentionstaff 2014-09-01 11:41:46 CEST
When fixing this we need to confirm that a subsequent AD Takeover works as well despite the differing spelling.
Comment 2 Stefan Gohmann univentionstaff 2014-09-02 08:57:57 CEST
Fixed: r53214
UCS 4 merge: r53215
YAML: r53217

I was able to reproduce this issue. After fixing univention-lib, I was able to join into a AD domain with a different spelling of the domainname.

The takeover failed because the copied sysvol directory was not found: Bug #35769
Comment 3 Arvid Requate univentionstaff 2014-09-08 16:17:11 CEST
Works and advisory is Ok.
Comment 4 Janek Walkenhorst univentionstaff 2014-09-10 17:35:47 CEST
http://errata.univention.de/ucs/3.2/191.html