Bug 35781 - Central App Center administration
Central App Center administration
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - App-Center
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Dirk Wiesenthal
Stefan Gohmann
: interim-3
Depends on:
Blocks: 36016 37565
  Show dependency treegraph
 
Reported: 2014-09-03 06:52 CEST by Stefan Gohmann
Modified: 2015-01-19 09:38 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
zarafa-pre-relogin.png (138.98 KB, image/png)
2014-11-08 18:28 CET, Stefan Gohmann
Details
zarafa-post-relogin.png (136.41 KB, image/png)
2014-11-08 18:28 CET, Stefan Gohmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-09-03 06:52:12 CEST
It should be possible to use one App Center UMC module to administrate the installed Apps in the domain. I think it should be possible to disable this feature via UCR and should should be enabled by default on all DC masters and DC backups.

The following things should be possible with the central App Center module:
 - show installation status of an App (on which host)
 - installation/uninstallation/update of an App on the local host or on a remote host
Comment 1 Dirk Wiesenthal univentionstaff 2014-09-30 10:00:41 CEST
Latest iteration (ready for QA):
  univention-management-console-module-appcenter 4.1.2-2.266.201409291728
Comment 2 Stefan Gohmann univentionstaff 2014-10-01 08:06:48 CEST
I'm not sure if these changes are the reason for the traceback. Nevertheless, you are the person who is able to fix it:

------------------------------------------------------------------------------
Die Ausführung des Kommandos setup/apps/query ist fehlgeschlagen:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/__init__.py", line 218, in execute
    func( request )
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 309, in _response
    result = _multi_response(self, request)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 449, in _response
    return list(function(self, iterator, *nones))
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/decorators.py", line 275, in _fake_func
    yield function(self, *args)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/setup/__init__.py", line 678, in apps_query
    return util.get_apps(True)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/setup/util.py", line 696, in get_apps
    _apps = [iapp.to_dict(package_manager) for iapp in applications if iapp.get('withoutrepository')]
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/app_center.py", line 911, in to_dict
    domainwide_managed = self.domainwide_managed(hosts)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/app_center.py", line 901, in domainwide_managed
    hosts = get_all_hosts(ucr=ucr)
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/util.py", line 108, in get_all_hosts
    lo = uldap.getMachineConnection(ldap_master=False)
  File "/usr/lib/pymodules/python2.7/univention/uldap.py", line 94, in getMachineConnection
    bindpw=open(secret_file).read()
IOError: [Errno 2] Datei oder Verzeichnis nicht gefunden: '/etc/machine.secret'
------------------------------------------------------------------------------

I get this message in system setup appliance mode.
Comment 3 Stefan Gohmann univentionstaff 2014-10-01 08:18:26 CEST
After the installation of an App on the local system, I will not asked for a restart of UMC. Thus new modules aren't available.
Comment 4 Dirk Wiesenthal univentionstaff 2014-10-17 17:04:23 CEST
(In reply to Stefan Gohmann from comment #3)
> After the installation of an App on the local system, I will not asked for a
> restart of UMC. Thus new modules aren't available.

Might be an error in reloadModules() of umc-frontend while the new design was applied. I tested it and it worked. I will set this to RESOLVED for now.
Comment 5 Stefan Gohmann univentionstaff 2014-10-19 19:52:48 CEST
Move all unfinished MS1 and MS2 bugs to RC.
Comment 6 Stefan Gohmann univentionstaff 2014-10-30 07:48:37 CET
Did you try to install a packages with master packages on a slave with the UMC on the master? I tried it several times but I got always:

---------------------------------------------------------------------------------
30.10.14 02:41:45.706  MODULE      ( PROCESS ) : Downloading "https://appcenter.software-univention.de/meta-inf/4.0/index
.json.gz"...
30.10.14 02:41:45.808  MODULE      ( PROCESS ) : 0 file(s) are new
30.10.14 02:41:45.827  MODULE      ( PROCESS ) : Try to install (install-schema) zarafa on None. Force? True. Only master
 packages? True. Prevent installation on other systems? True. Only dry run? None.
30.10.14 02:41:45.827  MODULE      ( PROCESS ) : The command has failed: Another package operation is in progress
---------------------------------------------------------------------------------
Comment 7 Dirk Wiesenthal univentionstaff 2014-10-31 03:48:19 CET
Fixed in univention-lib and umc-appcenter. Progress message is still a bit weird...

"Output from slave: Output from master: Installing package" because of the double remote installation. But I do not want to add even more complexity by checking whether localhost is master (as opposed to "target host") and then install yet again differently.

Maybe we remove the prefix "Output from %s: " completely?
Comment 8 Stefan Gohmann univentionstaff 2014-10-31 09:37:21 CET
(In reply to Dirk Wiesenthal from comment #7)
> Maybe we remove the prefix "Output from %s: " completely?

Yes, please.
Comment 9 Stefan Gohmann univentionstaff 2014-11-03 17:40:51 CET
As discussed, we need a UMC restart / reload after an app has been installed. Otherwise extended attributes are not shown.
Comment 10 Dirk Wiesenthal univentionstaff 2014-11-06 15:34:23 CET
Clearing the UDM frontend cache in
  univention-management-console-module-appcenter 4.1.15-7.292.201411061411
Comment 11 Stefan Gohmann univentionstaff 2014-11-08 18:27:38 CET
Nearly perfect, just one thing. See attached screenshots:
 zarafa-pre-relogin.png
 zarafa-post-relogin.png

Before I logout / login the field "Zarafa role" is not a drop down.
Comment 12 Stefan Gohmann univentionstaff 2014-11-08 18:28:04 CET
Created attachment 6327 [details]
zarafa-pre-relogin.png
Comment 13 Stefan Gohmann univentionstaff 2014-11-08 18:28:33 CET
Created attachment 6328 [details]
zarafa-post-relogin.png
Comment 14 Alexander Kläser univentionstaff 2014-11-10 10:25:07 CET
(In reply to Stefan Gohmann from comment #11)
> Nearly perfect, just one thing. See attached screenshots:
>  zarafa-pre-relogin.png
>  zarafa-post-relogin.png
> 
> Before I logout / login the field "Zarafa role" is not a drop down.

Maybe a problem with syntaxes?
Comment 15 Dirk Wiesenthal univentionstaff 2014-11-11 16:12:17 CET
I am not able to reproduce this reliably. For now, I added a tools.askReload() after installation.

Should be further investigated, though, as this may be a bug in UDM caching (frontend and/or backend).
Comment 16 Stefan Gohmann univentionstaff 2014-11-12 07:51:30 CET
(In reply to Dirk Wiesenthal from comment #15)
> I am not able to reproduce this reliably. For now, I added a
> tools.askReload() after installation.

OK, it works now.
Comment 17 Stefan Gohmann univentionstaff 2014-11-26 06:55:25 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".