Bug 35864 - Network setup check
Network setup check
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC - System diagnostic
UCS 4.0
Other Linux
: P5 enhancement (vote)
: UCS 4.0
Assigned To: Florian Best
Felix Botner
: interim-3
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-10 08:28 CEST by Stefan Gohmann
Modified: 2014-11-26 06:55 CET (History)
0 users

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-09-10 08:28:56 CEST
We should add a system diagnostic plugin which checks the network setup, for example is the gateway reachable, does the DNS server and the name server answer DNS requests. If an error occurs, the module should redirect to the system setup network module.
Comment 1 Janis Meybohm univentionstaff 2014-09-10 08:40:03 CEST
Maybe add a test for an eventually configured http proxy too.
Comment 2 Florian Best univentionstaff 2014-10-02 11:13:20 CEST
Three plugins have been added:

gateway.py:
pings the gateway with a maximum timeout of 500ms. Refers on failure to the Setup - Network module.

proxy.py:
if proxy/http is configured it tries to get the content of http://univention.de via the proxy (is it OK to use that domain for testing purposes?)
It offers a button to disable the proxy server completely. → remove this?
TODO: find out a little bit more about the cause of the failure (wrong credentials, proxy down, etc.).

nameserver.py:
Tries to reach every nameserver[1-3] doing a lookup of the IP for the own hostname.
Tries to reach every dns/forwarder[1-3] doing a lookup of the IP for www.univention.de.
If the domain does not exists the test doesn't fail. Every other error fails (e.g. timeout).
Comment 3 Florian Best univentionstaff 2014-10-02 17:48:58 CEST
The texts have been adapted, some code cleanup was done, proxy.py has been enhanced to give more detailed information.
Comment 4 Stefan Gohmann univentionstaff 2014-10-19 19:52:43 CEST
Move all unfinished MS1 and MS2 bugs to RC.
Comment 5 Felix Botner univentionstaff 2014-10-29 16:20:55 CET
please remove the notifications as they are very confusing
Comment 6 Florian Best univentionstaff 2014-10-29 17:26:39 CET
notifications have been removed.
Comment 7 Felix Botner univentionstaff 2014-10-30 11:20:40 CET
FAIL - proxy with basic authentication does not work
       Why do we need a "disable proxy" button here?

OK - gateway test

OK - nameserver/dnsforwarder test
     Maybe we should add a hint that the dns/forwarder must be 
     able to resolve "www.univention.de"?

Translations missing for:

Gateway is not reachable

The gatway 31324 could not be ...

(*)

Nameserver(s) are not responsive

1 of the configured nameservers ...

(*)

Proxy Server Failure

There was an error using the ...
Comment 8 Florian Best univentionstaff 2014-10-30 13:56:22 CET
(In reply to Felix Botner from comment #7)
> FAIL - proxy with basic authentication does not work
>        Why do we need a "disable proxy" button here?
fixed, curl is able to do BASIC, DIGEST and NTLM.

> OK - nameserver/dnsforwarder test
>      Maybe we should add a hint that the dns/forwarder must be 
>      able to resolve "www.univention.de"?
hint added

> Translations missing for:
→ Translations fixed, they were missing in the .mo file because dh_umc.py did not add subdirectories.

Package currently builds.
Comment 9 Felix Botner univentionstaff 2014-10-31 12:23:33 CET
OK
Comment 10 Stefan Gohmann univentionstaff 2014-11-26 06:55:10 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".