Bug 35911 - Traceback in proof_uniqueMembers
Traceback in proof_uniqueMembers
Status: VERIFIED FIXED
Product: UCS Test
Classification: Unclassified
Component: LDAP
unspecified
Other Linux
: P5 normal (vote)
: ---
Assigned To: Dmitry Galkin
:
Depends on: 33030
Blocks:
  Show dependency treegraph
 
Reported: 2014-09-11 15:06 CEST by Stefan Gohmann
Modified: 2016-10-12 07:48 CEST (History)
0 users

See Also:
What kind of report is it?: Development Internal
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
Test 52proofuniquemember passes with tracebacks (2.90 KB, text/plain)
2014-11-18 11:30 CET, Dmitry Galkin
Details
Test 52proofuniquemember failure (1.87 KB, text/plain)
2014-11-18 11:31 CET, Dmitry Galkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-09-11 15:06:08 CEST
+++ This bug was initially created as a clone of Bug #33030 +++

Traceback (most recent call last):
  File "./proof_uniqueMembers", line 239, in <module>
    main()
  File "./proof_uniqueMembers", line 230, in main
    check_groups(conn, basedn)
  File "./proof_uniqueMembers", line 136, in check_groups
    count_changes += check_groups_by_dn(conn, group_dn, group)
  File "./proof_uniqueMembers", line 150, in check_groups_by_dn
    member_filter, base = member_dn.split(',', 1)
ValueError: need more than 1 value to unpack
Comment 1 Dmitry Galkin univentionstaff 2014-11-18 11:30:38 CET
Cannot reproduce this specific problem, neither in my UCS 3.2-3, nor in UCS 4.0. Actually, there is a following construction now:

                try:
                        member_filter, base = member_dn.split(',', 1)
                except ValueError:
                        remmembers.add(member_dn)
                        continue


So ValueError won't be raised. 

The problem I've noticed is when I run the 00_base/52proofuniquemember --> the test passes although there are tracebacks in the output, this should not happen I believe. Also, if I eliminate the sources of the traces in my env, the test would fail.
Comment 2 Dmitry Galkin univentionstaff 2014-11-18 11:30:53 CET
Created attachment 6404 [details]
Test 52proofuniquemember passes with tracebacks
Comment 3 Dmitry Galkin univentionstaff 2014-11-18 11:31:48 CET
Created attachment 6405 [details]
Test 52proofuniquemember failure
Comment 4 Dmitry Galkin univentionstaff 2014-11-18 11:39:48 CET
(In reply to Dmitry Galkin from comment #1)

> The problem I've noticed is when I run the 00_base/52proofuniquemember -->
> the test passes although there are tracebacks in the output, this should not
> happen I believe.

Same case observed in Jenkins:
http://jenkins.knut.univention.de:8080/job/UCS-4.0/job/UCS-4.0-0/job/Autotest%20MultiEnv/65/SambaVersion=s4,Systemrolle=master/testReport/00_base/52proofuniquemember/test/


Opened another Bug #36799
Comment 5 Stefan Gohmann univentionstaff 2014-12-09 06:35:15 CET
(In reply to Dmitry Galkin from comment #4)
> Opened another Bug #36799

OK, I assigned the bug to you.

For this bug, please add a new test case with an empty uniqueMember entry. This was the original cause of Bug #33030.
Comment 6 Dmitry Galkin univentionstaff 2014-12-15 17:02:38 CET
(In reply to Stefan Gohmann from comment #5)
> For this bug, please add a new test case with an empty uniqueMember entry.
> This was the original cause of Bug #33030.

r56846:
  * 01_base/52proofuniquemember_empty_attribute: test how 
    proof_uniqueMembers handles the empty 'uniqueMember' attribute (Bug #35911)
Comment 7 Dmitry Galkin univentionstaff 2014-12-15 17:07:07 CET
(In reply to Dmitry Galkin from comment #6)
> r56846:
>   * 01_base/52proofuniquemember_empty_attribute: test how 
>     proof_uniqueMembers handles the empty 'uniqueMember' attribute (Bug
> #35911)


Note: the "univention-s4-connector | univention-ad-connector" packages were added due to '/usr/share/ucs-test/lib/ldap_glue.py' which imports 'compatible_modstring'. Without those, the attribute will be deleted if set to "" or will cause a traceback if set to another value..
Comment 8 Stefan Gohmann univentionstaff 2016-10-12 07:48:11 CEST
For this bug is no separate QA needed.