Bug 36097 - univention-run-join-script parse for binddn failed in some cases
univention-run-join-script parse for binddn failed in some cases
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: Join (univention-join)
UCS 4.2
Other Linux
: P5 normal (vote)
: UCS 4.3-0-errata
Assigned To: Richard Ulmer
Jürn Brodersen
:
: 45221 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-08 16:14 CEST by Tobias Birkefeld
Modified: 2018-05-29 16:50 CEST (History)
5 users (show)

See Also:
What kind of report is it?: Bug Report
What type of bug is this?: 1: Cosmetic issue or missing function but workaround exists
Who will be affected by this bug?: 2: Will only affect a few installed domains
How will those affected feel about the bug?: 5: Blocking further progress on the daily work
User Pain: 0.057
Enterprise Customer affected?: Yes
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number: 2018022321000354
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Birkefeld univentionstaff 2014-10-08 16:14:50 CEST
Error message:
-----8<------8<-----
**************************************************************************
* Running join scripts failed!                                           *
**************************************************************************
* Message:  binddn for user Administrator not unique: uid=Administrator,cn=users,dc=tbirkefe,dc=local
  description: foobar
**************************************************************************

root@slave01:~# udm users/user list --filter uid=Administrator|grep description
  description: fooDN: bar
-----8<------8<-----

The script univention-run-join-scripts parse for DN is not perfect. Change line 159 to following:

-        sed -ne 's|DN: ||p'))
+        sed -ne 's|^DN: ||p'))
Comment 1 Christina Scheinig univentionstaff 2018-02-23 14:05:43 CET
A customer cannot run univention-run-join-scripts on his DC-Backupserver caused by the same issue
Comment 2 Richard Ulmer univentionstaff 2018-03-19 10:11:41 CET
I have made the suggested improvment to the sed script. I also narrowed down the sed address to only search in the second line, to further improve the robustness. The sed expression now looks like this: "sed -n '2s/^DN: //p'"

univention-join (10.0.0-4):
e3bd46c6f8b8 | Bug #36097: Refine sed command for filtering the DN out of an UDM output
60b7ac7eed12 | Bug #36097: Add yaml file
Comment 3 Jürn Brodersen univentionstaff 2018-03-29 16:22:56 CEST
What I tested:

Set first name to "DN: foobar"
univention-run-join-scripts on slave works -> OK

Small YAML change:
[4.3-0 28f386ada8] Bug #36097: fix YAML

-> Verified
Comment 4 Philipp Hahn univentionstaff 2018-04-04 16:35:25 CEST
<http://errata.software-univention.de/ucs/4.3/11.html>
Comment 5 Jürn Brodersen univentionstaff 2018-05-29 16:50:12 CEST
*** Bug 45221 has been marked as a duplicate of this bug. ***