Bug 36144 - Instance not available after creation
Instance not available after creation
Product: UCS
Classification: Unclassified
Component: Virtualization - UVMM
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Erik Damrose
Stefan Gohmann
: interim-3
Depends on:
  Show dependency treegraph
Reported: 2014-10-11 08:20 CEST by Stefan Gohmann
Modified: 2014-11-26 06:55 CET (History)
1 user (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Flags outvoted (downgraded) after PO Review:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-10-11 08:20:28 CEST
After creating a VM, I need to wait and click after some time on the search button.

It should be shown a pre-state of the VM or the module should wait for some time. For example for 60 seconds. If the VM isn't available after 60 seconds, a message should be shown that the creation could take some time.
Comment 1 Andreas Peichert univentionstaff 2014-10-23 16:10:16 CEST
- show progressbar if instance is not "running" within 60 seconds:
- display message after 60 seconds 'The instance {label} is still not running. Please wait and to update the view, click on "Search"'
- every second the state is checked and the grid-view is updated

OpenStack test scenario:
- add one or two m1.xlarge instances, wait 60 seconds, wizard closes and the message is displayed (later the instance state will change from "pending" to "crashed")
- adding more m1.xlarge instances will fail and a "Quota exceeded" error message from umcp/libcloud is displayed but the wizard is still open (for choosing a smaller size).

r54869 univention-virtual-machine-manager-daemon (4.0.3-18)
Comment 2 Stefan Gohmann univentionstaff 2014-10-27 09:09:45 CET
In my tests the progress stopped at 33 %. In this case we shouldn't use a progress bar. We have in other modules waiting animations.
Comment 3 Erik Damrose univentionstaff 2014-10-30 12:01:22 CET
Added infinite progress bar to uvmm module. It is shown in case the duration respectively steps are not known when the progressbar is created.

r55136 univention-virtual-machine-manager-daemon 4.0.6-1
Comment 4 Stefan Gohmann univentionstaff 2014-11-01 14:10:35 CET
Yes, that works now as expected.
Comment 5 Stefan Gohmann univentionstaff 2014-11-26 06:55:11 CET
UCS 4.0-0 has been released:

If this error occurs again, please use "Clone This Bug".