Bug 36286 - ImportError: No module named appcenter.app
ImportError: No module named appcenter.app
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: App Center
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0
Assigned To: Arvid Requate
Drees Dormann
: interim-3
: 36294 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-10-23 19:49 CEST by Stefan Gohmann
Modified: 2014-11-26 06:55 CET (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments
updater.log (1.27 MB, application/text)
2014-10-23 19:49 CEST, Stefan Gohmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Gohmann univentionstaff 2014-10-23 19:49:34 CEST
Created attachment 6212 [details]
updater.log

Some app center test fail after upgrading to UCS 4:

Traceback (most recent call last):
  File "43_installed_apps_check_packages_available_for_i386", line 12, in <module>
    import univention.management.console.modules.appcenter.app_center as app
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/__init__.py", line 59, in <module>
    from app_center import Application, LICENSE
  File "/usr/lib/pymodules/python2.7/univention/management/console/modules/appcenter/app_center.py", line 73, in <module>
    import univention.admin.handlers.appcenter.app as appcenter_udm_module
ImportError: No module named appcenter.app

http://jenkins.knut.univention.de:8080/job/UCS-4.0/job/UCS-4.0-0/job/UCS%203.2%20to%204.0%20Autotest%20MultiEnv/SambaVersion=s3,Systemrolle=master/lastCompletedBuild/testReport/20_appcenter/43_installed_apps_check_packages_available_for_i386/test/
Comment 1 Stefan Gohmann univentionstaff 2014-10-23 19:53:54 CEST
From another test case:

Traceback (most recent call last):
  File "41_udm_create_full_app", line 69, in <module>
    server = server,
  File "/usr/lib/pymodules/python2.7/univention/testing/udm.py", line 186, in create_object
    raise UCSTestUDM_CreateUDMObjectFailed({'module': modulename, 'kwargs': kwargs, 'returncode': child.returncode, 'stdout': stdout, 'stderr': stderr})
univention.testing.udm.UCSTestUDM_CreateUDMObjectFailed: {'returncode': 3, 'stdout': 'unknown module appcenter/app.\n\nAvailable Modules are:\n  computers/computer\n  computers/domaincontroller_backup\n
Comment 2 Arvid Requate univentionstaff 2014-10-27 15:15:51 CET
*** Bug 36294 has been marked as a duplicate of this bug. ***
Comment 3 Arvid Requate univentionstaff 2014-10-28 18:59:50 CET
Fixed, jenkins jobs look good.
Comment 4 Drees Dormann univentionstaff 2014-10-31 14:33:20 CET
tests are looking good

changelog ok
Comment 5 Stefan Gohmann univentionstaff 2014-11-26 06:55:54 CET
UCS 4.0-0 has been released:
 http://docs.univention.de/release-notes-4.0-0-en.html
 http://docs.univention.de/release-notes-4.0-0-de.html

If this error occurs again, please use "Clone This Bug".