Bug 36385 - app.getModule is non-deterministic regarding flavored UMC modules
app.getModule is non-deterministic regarding flavored UMC modules
Status: RESOLVED DUPLICATE of bug 38544
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: ---
Assigned To: UMC maintainers
:
: 38613 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-03 09:31 CET by Dirk Wiesenthal
Modified: 2015-05-29 15:45 CEST (History)
2 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dirk Wiesenthal univentionstaff 2014-11-03 09:31:09 CET
app.getModule('appcenter') returns the App Center in Firefox, but Package Management in Chrome. The fix is to say app.getModule('appcenter', 'appcenter').

Nevertheless, a non-deterministic behaviour is problematic. Better return nothing than "the first" of a dictionary (or deferred.reject()).
Comment 1 Florian Best univentionstaff 2015-05-29 11:33:17 CEST

*** This bug has been marked as a duplicate of bug 38544 ***
Comment 2 Florian Best univentionstaff 2015-05-29 15:45:00 CEST
*** Bug 38613 has been marked as a duplicate of this bug. ***