Bug 36445 - Firefox "resend" dialog after UMC logout
Firefox "resend" dialog after UMC logout
Status: CLOSED FIXED
Product: UCS
Classification: Unclassified
Component: UMC (Generic)
UCS 4.0
Other Linux
: P5 normal (vote)
: UCS 4.0-0-errata
Assigned To: Florian Best
Alexander Kramer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2014-11-05 12:27 CET by Felix Botner
Modified: 2015-02-04 15:57 CET (History)
4 users (show)

See Also:
What kind of report is it?: ---
What type of bug is this?: ---
Who will be affected by this bug?: ---
How will those affected feel about the bug?: ---
User Pain:
Enterprise Customer affected?:
School Customer affected?:
ISV affected?:
Waiting Support:
Ticket number:
Bug group (optional):
Max CVSS v3 score:
best: Patch_Available+


Attachments
firefox-resend.png (461.79 KB, image/png)
2014-11-05 12:27 CET, Felix Botner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Botner univentionstaff 2014-11-05 12:27:42 CET
Created attachment 6306 [details]
firefox-resend.png

After i logout from UMC Firefox asks me about resending data (?).
Comment 1 Florian Best univentionstaff 2014-11-05 12:33:08 CET
This has to do with the login because there in the iframe is a POST request done.
Comment 2 Florian Best univentionstaff 2014-11-05 12:35:39 CET
http://stackoverflow.com/questions/4327236/stop-browsers-asking-to-resend-form-data-on-refresh

Maybe it helps to reload the iframe content (this already happens by a redirect in _blank.html?!)
Comment 3 Florian Best univentionstaff 2014-11-17 11:00:48 CET
diff --git a/ucs-4.0-0/management/univention-management-console-frontend/Makefile b/ucs-4.0-0/management/univention-management-console-frontend/Makefile
index 0d40e6b..0ffa2b8 100644
--- a/ucs-4.0-0/management/univention-management-console-frontend/Makefile
+++ b/ucs-4.0-0/management/univention-management-console-frontend/Makefile
@@ -87 +87 @@ $(tmpDir)/umc/app/login.html: login.html
-       cp $@ $(dir $@)/blank.html
+       cp blank.html $(dir $@)/blank.html
Comment 4 Florian Best univentionstaff 2015-01-30 10:57:26 CET
blank.html has been reimplemented so that a redirection to login.html using HTTP GET is done again.
Fix: svn r57682 (+ svn r57685)
Package: univention-management-console-frontend
Version: 4.1.106-11.993.201501301040
YAML: 2015-01-30-univention-management-console-frontend.yaml
Comment 5 Alexander Kramer univentionstaff 2015-02-02 15:12:13 CET
hint - how to reproduce:
just import the licence again or install kde desktop enviroment. both cases will ask to reload the umc. so i got the message in firefox version 34.0

OK - with 4.1.106-11.993.201501301040 the message in firefox disapeared (chromium  37.0.2062.120 worked also fine)
OK - yaml
OK - debian/changelog
Comment 6 Janek Walkenhorst univentionstaff 2015-02-04 15:57:58 CET
<http://errata.univention.de/ucs/4.0/76.html>